MikroTik nustatymai - atmintinė 1

MikroTik nustatymai – atmintinė

Tekstas atnaujintas

Surašysiu Mikrotik nustatymus kuriuos pats naudoju. Kai kuriuos nustatymus galima ir kitaip susikonfigūruoti tvarkingiau, bet neturiu laiko nagrinėti. Svarbu viskas veikia ko man reikia.

Visus nustatymus patogu keisti naudojant WinBox.

Turima įranga: hAP ac²

Cloud

Pirmas nustatymas būtų IP>Cloud įjungimas. Pagrinde tai suteikia tavo IP adresui nemokamą subdomain. Nereikės vesti namų IP adreso norint pasiekti. Taip pat padeda jeigu WAN adresas keičiasi.

MikroTik nustatymai - atmintinė 2
/ip cloud
set ddns-enabled=yes

Telios išmaniosios tv pajungimas naudojant switch nustatymus

Apie telia pajungimą jau buvau užsiminęs routerio apžvalgoje. Ten aprašyta naudojant bridge.

Pagrinde sukuriamas vlan6, interface skiltyje. Toliau viskas sudedama į bridge ir priskiriama prie tam tikrų portų (turiu įtarimų, kad viską įmanoma pasidaryti, kiek kitaip per switch skiltį, tik kol kas nenagrinėjau to).

Viename bloge radau komandas, kaip pasileisti panaudojus tik switch nustatymus ir nekuriant jokių bridge, tai atrodoo taip:

switch dalis, turint telia iptv mikrotik

Pagal pavadinimus galima suprasti jog ether4-STB ir ether5-STB turi nustatymus reikalingus priedėliams, nustatom lygiai taip pat, kaip pavaizduota.

WAN nustatymus taip pat svarbu taip nustatyti. Toliau kitką paliekam kaip buvo.

switch dalis, turint telia iptv mikrotikm antra dalis

Šitoje vietoje svarbu parašyti jog vlan id 6 ir sudėti portus, pirmas būtinai WAN, toliau eina priedėlio portai.

Komandas pridėsiu vėliau.

Beje, naudojant tokį būdą nesugalvojau, kaip pasileisti LRT kanalą per VLC.

LRT kanalas naudojant bridge

Kaip žinia Telia naudoja DRM apsaugas (kaip apeiti apsaugas, nežinau). Bet kažkodėl leidžia žiūrėti per VLC: LRT 1080p ir LRT 720p. Keista jog SD versijos neduoda.

Apžvalgoje nėra aprašyta, kaip pasileisti udp srautą į bridge-lan. Tad aprašysiu tai čia.

Aišku jau reikia būti susitvarkius jog rodytų ir patys priedėliai.

IP>DHCP Client

Ties interface nurodyti bridge interface kuriame veikia IPTV. Nurodžius turi priskirti IP adresą kuris prasideda 10.

MikroTik nustatymai - atmintinė 3
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=wan
add add-default-route=no disabled=no interface=bridge-iptv use-peer-dns=no

Routing>Igmpproxy

Priskiriam tą patį bridge interface kuriame veikia IPTV ir bridge-lan kuriame veikia kiti įrenginiai.

Taip pat suvesti skaičius kurie suvesti pas mane ties alternative subnets.

/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add interface=bridge-lan
add alternative-subnets=10.0.0.0/7,224.0.0.0/4 interface=bridge-iptv upstream=yes
MikroTik nustatymai - atmintinė 4

Nuo dabar turėtų leisti pasiekti udp://@ adresus per VLC.

Tam reikalui naudoju astra-relay kuri įrašyta į NUC.

MikroTik nustatymai - atmintinė 5

Prievadų (portų) atidarymas

Savo įrangą visada noriu pasiektu iš išorės, tad reikia atidaryti kelis portus.

Jeigu noriu pasiekti routerį:

IP>Firewall>Filter Rules

MikroTik nustatymai - atmintinė 6

Dažniausia naudojamas 80 portas routerio pasiekimui. Kadangi užimtas šis portas kitiems reikalams, tai teko MikroTik WEB portą  pakeisti į 81.

MikroTik nustatymai - atmintinė 7

Jeigu norim pasiekti su Winbox per išorę tada vietoje mano naudojamo porto 81 pakeisti į 8291.

/ip firewall filter add action=accept chain=input comment=winbox dst-port=8291 protocol=tcp

Jeigu norim pasiekti įrenginį kuris yra vietiniam tikle, reikės naudoti kitą komandą.

IP>Firewall>NAT

Reiktų sukurti WAN-IP adress list, kad leistų, būnant vidiniam tinkle, pasiekti vidinį tinklą su išoriniu adresu. Skamba gan kvailai, bet su tuo susidūriau naudojant tik Mikrotik.

MikroTik nustatymai - atmintinė 8
/ip firewall address-list add list=WAN-IP address=išorinis_adresas

Pradedam kurti taisyklę IP>Firewall>NAT

MikroTik nustatymai - atmintinė 9

Dst. Port. tai portas kuris bus pasiekiamas iš išorės.

MikroTik nustatymai - atmintinė 10
MikroTik nustatymai - atmintinė 11

To Addresses tai adresas vietiniam tinkle. To Ports tai portas vietiniam tinkle į kurį bus nukreipta.

/ip firewall nat add action=dst-nat chain=dstnat dst-port=943 
 dst-address-list=WAN-IP protocol=tcp to-addresses=192.168.1.200 to-ports=943
MikroTik nustatymai - atmintinė 12

Extra skiltyje galima pridėti dar papildomų nustatymų prie atidaryto porto. Naudoju Time reikšmę kuri atidaro portą tik tam tikru laiku.


DNS nustatymų pakeitimas

Kaip žinia vis daugiau puslapių pradedama blokuoti (lažybų puslapiai, nelegalūs puslapiai). Pats blokavimas gan paprastas ir paremta tiesiog DNS adresais. Kreipiantis į domeno adresą o interneto tiekėjas tiesiog jus nukreipia kitur. 

Tad pasikeičiam DNS adresus ir pamirštam blokavimus.

Siūlau naudoti Cloudflare (1.1.1.1, 1.0.0.1) adresus, atsarginius Google (8.8.8.8, 8.4.4.8).

/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1,8.8.8.8,8.4.4.8

Patiko puslapio turinys?
Prenumeruok naujienas.

Gauk žinutę nuo manęs apie naujus įrašus.
Invalid email address
Prižadu, spamas nebus siunčiamas.

5 komentarai

  • O ne paprasčiau buvo konfigūracijos export’ą konsolėje padaryt, kaip kad priimta mikrotiko forumuose?

    Reply
    • Vėliau bus. Kol kas su komandom daug nedraugauju MikroTike. Patinka winbox tiesiog.
      Atnaujinta – pridėjau kelias terminal komandas.

  • Sveiki Evaldai,

    Bandau pasidaryti konfiguracija pagal jusu aprasyma.
    Routeris neranda: „Upstream interface“:

    /routing igmp-proxy mfc

    # GROUP SOURCE UPSTREAM-INTERFACE ACTIVE-DOWNSTREAM…
    0 AD 239.2.2.240 10.30.134.12 *FFFFFFFF

    ———————————————————————

    /routing igmp-proxy interface print status

    0 interface=bridge-lan threshold=1 alternative-subnets=““ upstream=no
    querier=yes source-ip-address=192.168.6.1 rx-bytes=0 rx-packets=0
    tx-bytes=0 tx-packets=0

    1 U interface=bridge-iptv threshold=1
    alternative-subnets=10.0.0.0/7,224.0.0.0/4 upstream=yes
    source-ip-address=10.158.47.120 rx-bytes=0 rx-packets=0 tx-bytes=0
    tx-packets=0

    Reply
  • port forwarding – tai kas paveikslėliuose nesutampa su tuo kas siūloma komandine eilute. Nieko neužsiminta kaip sukūrei WAN-IP list

    Reply

Komentarai

Scroll to Top