MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 1

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas

Tekstas atnaujintas

Kažkurią dieną būdamas prie PC, sugalvojau pažiūrėti kas routerių rinkoje dedasi.

Asus turi visai neblogą variantą AC58U, su Qualcomm IPQ4018 ir kaina prasideda nuo 70€, bet pagalvojus, kad Asus jau turėjau ir ne vieną modelį, norisi kažko įdomesnio.

Tada prisiminiau jog yra MikroTik, nuėjus į jų puslapį, iškart mane pasitiko jų pristatomos naujienos.

Ir vienas maršrutizatorius buvo labiau orientuotas į namų vartotojus – hAP ac².

Taip pat turintis IPQ-4018.

Tada pradėjau domėtis kur jį gauti.

MikroTik hAP ac² kaina

Kadangi tuo momentu jis dar buvo tik paskelbtas. Nusipirkti, kaip ir nebuvo dar įmanoma.

Pasitelkiant Google buvo rastos kelios internetinės parduotuvės kurios dar pristatymo datos nežinojo, reikėjo užklausti.

Iš lietuviškų parduotuvių kurios rašo jog turės, tuo metu buvo Katalita ir Skytech.

Katalita atrašė jog nuo Kovo 22 dienos galima tikėtis, o Skytech atrašė jog išvis nežino, nes tiekėjai neduoda žinoti, bet pasiūlė kitą modelį MikroTik’o.

Prasideda laukimas, kai pradėjau domėtis buvo Vasario galas…

Atėjus Kovo mėnesio galui vis dar niekur nėra, bet dar palaukus kelias dienas Katalita jau turėjo.

Su pristatymu gavosi 55€, hm Asus modelis su tokiu pačiu SOC kainuoja nuo 70€ (berods tik flash atmintis skiriasi ir, kad turi išorines antenas).

Patiko jog Katalita tikrai jį turėjo ir nereikėjo laukti dar kelias dienas kol gaus, tad pristatymas įvyko labai greitai.

Specifikacijos

MikroTik hAP ac² apžvalga - specifikacijos
Pagal gamintoją
Pilnas pavadinimasRBD52G-5HacD2HnD-TC
ArchitektūraARM 32bit
CPUIPQ-4018
CPU branduolių skaičius4
CPU dažnis716 MHz
Dydis34 x 119 x 98mm
Mikrotik licencija4
OS sistemaRouterOS
RAM128 MB
Vidinė atmintis16 MB
Vietos tipasFLASH
Darbinė temperatūra-40°C .. +50°C
Siūloma kaina pagal gamintoją€55

MikroTik’ai turi labai įdomius pavadinimus, bet skaitant jų WiKi, supratau, kad tai tiesiog iš tam tikrų raidžių sudėtas pavadinimas, jeigu išmoksti tas raides, tai labai greitai gali suprasti, kas per funkcionalumas routerio.

Kaip atsikoduoja pavadinimas aprašyta čia.

Pirmas dalykas kuris krenta į akį atidarius dėžutę tai dydis. Beje pati dėžutė labai paprasta lyginant su kitas turėtais. Gal ir kaina dėl to mažesnė 🙂

Dydis bene 4 kartus mažesnis negu buvęs WRT1900ACv2 !! Kam reikia mažai vietos užimančio routerio, labai geras variantas.

Maršrutizatoriaus pajungimas

Tik pajungus į tinklą, automatiškai pasigaunamas IP adresas ir internetas jau veikia.

Gan patogus pagrindinių nustatymų langas:

MikroTik hAP ac² nustatymai

Iš automatinių nustatymų pastebėjau, jog routerio adresas bus 192.168.88.1 ir WiFi bus be kodo. Jeigu neturi  laido, kaip pasijungti įmanoma prisijungiant per WiFi ir susitvarkyti bent pradinius nustatymus.

Pas mane jau pakeista Local Network ir DHCP range, pripratau prie tokių, kažkaip keisti nesinori 🙂

Beje Mikrotiką galima tvarkyti trejais skirtingais būdais:

  1. Komandinė eilutė
  2. Per naršyklę, pradinis http adresas 192.168.88.1
  3. WinBox programa kurią reikia atsisiųsti.

Patogiausias tvarkymas naudojant WinBox:

MikroTik hAP ac² winbox

Patogiausias nes uždarius WinBox ir mėginant vėl prisijungti, atidaromi tie patys langai kurie buvo atidaryti prieš tai ir langus gali susidėlioti, kad matytum kelis.

Komandine eilute nelabai teko dirbti, tik minimaliai nes komandos yra tam tikros, kurios nelabai kitur naudojamas su Linux. Per laiką įmanoma įsidėmėti nes skaitant WiKi viskas surašyta komandomis.

Per naršyklę galima prisijungti iš išorės, kai neturim WinBox programos po ranka.

Taip pat dar yra ir Android programa, kurioje ne visi routerio nustatymai pateikti.

 WAN-LAN ir CPU apkrovos

Kažkokių problemų naudojant laidus neturėjau.

Man rodos Telia vakarais pjauna jau grybą:

owner@owner-desktop ~ $ /home/owner/speedtest-cli --server 3556
Retrieving speedtest.net configuration...
Testing from Telia Lietuva, AB (88.119.xx.xx)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by Balticum TV (Klaipeda) [2.15 km]: 11.904 ms
Testing download speed.......................................................... ......................
Download: 723.17 Mbit/s
Testing upload speed............................................................ ....................................
Upload: 568.23 Mbit/s

Kitos dienos ryte:

owner@owner-desktop ~ $ /home/owner/speedtest-cli --server 1385
Retrieving speedtest.net configuration...
Testing from Telia Lietuva, AB (88.119.xx.xx)...
Retrieving speedtest.net server list...
Retrieving information for the selected server...
Hosted by Telia Lietuva, AB (Klaipeda) [2.15 km]: 3.141 ms
Testing download speed................................................................................
Download: 848.08 Mbit/s
Testing upload speed................................................................................................
Upload: 608.55 Mbit/s
MikroTik hAP ac² cpu
CPU apkrova darant speedtest.
MikroTik hAP ac² apkrova
Siunčiant torrent laidu.

LAN greitis, kaip ir priklauso 1Gbps.

WiFi greitis 2.4Ghz ir 5Ghz

MikroTik’ai nelabai pasižymi WiFi greičiais.

Bet šis naujas modelis turi 2.4Ghz ir 5Ghz.

Įdomu tai, kad WiFi greitis buvo mažas su stabilia RouterOS versija.

Keliant failus per samba nuo NUC kuris pajungtas per laidą, greitis buvo tragiškas, šokinėjo nuo 5MB/s iki 20MB/s kas kelias sekundes.

Iš pradžių nesupratau, kas blogai, bet pabandžius RC versiją, magiškai greitis jau kažkiek susitvarkė:

MikroTik hAP ac² samba kelimo greitis

Dar banguoja keliant failus, bet gyventi galima. WRT1900ACv2 su šituo reikalu geriau tvarkėsi.

Testuojant iš kelių metrų.

Laptopas Intel AC7260:

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 2
5Ghz
MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 3
2.4Ghz

Telefonas Oneplus 3:

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 4
2.4Ghz
MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 5
5Ghz

Tolimiausiam buto taške lyginant su kitais turėtais routeriais tai per viduriuką rezultatas gaunasi, per kelias storas sienas su PC surenka 30Mbps, daugiausiai toje vietoje eidavo surinkti 70Mbps su Asus AC66U.

Kodėl pasirinkau MikroTik routerį?

Nustatymai, nustatymai ir dar kartą nustatymai.

Jų gausybė lyginant su visais namų routeriais.

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 6

Kad per visus nustatymus praeiti, reikia gero vakaro.

Aišku, pagrindinius dalykus galima greitai susitvarkyti, bet norint naudoti visas teikiamas galimybes reikia pasėdėti prie nustatymų.

Vien norint atidaryti portą į išorę užtrukau apie pusę valandos.

Atidarius portą atsirado dar viena problema, kad su išoriniu IP adresu negaliu pasiekti vidinio LAN tinklo būnant LANe.

Dar papildomai teko skirti laiko ties tuo.

Kad ir paprastą dalyką norint atlikti reikia pasidomėti, kaip tai padaryti.

Bet nuo to tik įdomiau.

Patiko jog RotuerOS turi ir įvairių įrankiu testuojant tinklą.

Naršydamas po nustatymus radau neblogą greičio testavimo įrankį, kuris vadinimas btest. Pačiam RouterOS reikia įjungti btest (tools>btest server), tada parsisiunčiam btest programą į kompiuterį.

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 7

Atsidarius programai, suvedam duomenis ir spaudžiam start.

Taigi matom jog šiuo metu maksimalus greitis ~340Mbps.

Taip pat galima testuoti per viešai prieinamą serverį.

Išmaniosios Telios TV pajungimas naudojant MikroTik

Naujo įrašo nelabai noriu kurti, tai tiesiog aprašysiu čia, kadangi daug nustatymų nereikia keisti, jog paleisti STB.

Internete klaidžioja pamoka, kaip pasijungti:

Mikrotik + TEO GALA TV

Maniau jog bus viskas paprasta, pagal pamoką, bet…

Pasirodo MikroTik atnaujino savo nustatymus ir panaikino master-port funkciją. Tad pagal pamoką, pusę komandų veikia, o toliau routeris mėto klaidas.

Master-port funkcijos tiesiog nėra.

Pradėjus Googlint kodėl neveikia master-port funkcija, pasirodo ties kažkuria RouterOS versija tai panaikino.

Dabar MikroTik siūlo tiesiog viską dėti į bridge. Panašiai, kaip naudojant TP-Link routerius kurie neturi atskiro eth, tarp switch nustatymų.

MikroTik hAP ac² apžvalga ir Telia IPTV pajungimas 8

Atsidarius interface, reikia sukurti vlan6 priskiriant interface wan.

Tada einam į bridge skiltį ir sukuriam naują bridge kuris bus skirtas IPTV.

Užtenka tik persivadinti, kaip norit, daugiau nieko keisti nereikia.

Tada einam į ports dalį, priskiriam tuos LAN portus katruos jungiam STB į sukurtą bridge.

Nepamirštam paspausti + ir pridėti vlan6 į tą bridge, mano atveju iptv-vlan6.

Realiai teorija tokia jog sujungiam viską, tiek portus, tiek tą sukurtą vlan6 į vieną bridge ir turim vaizdą per STB.

Taip pat reiktų įrašyti multicast paketą iš MikroTik puslapio.

Prie routerio modelio yra extra packages, kuriame yra įvairių paketų, kurių nėra pagal nutilėjimą.

Mums reiks multicast paketo, tada per WinBox atsidarom files ir nutempiam iš desktop tą failą, pekraunam routerį ir tada tarp packages galima įjungti.

Kaip pajungti imgpproxy dar nesupratau, gal kas gali papildyti komentaruose?

Sužinojau, kaip ir aprašyta kitame įraše.

Reziume – pigus, galingas routeris

Supratau, kad tai tikrai naujas produktas ir programinė įranga dar nėra išbaigta, dar prie to manau prisideda jog tai ARM SOC, prie kurio MikroTik atrodo neseniai pradėjo dirbti, nes visada eidavo Mips.

Current versija turėjo bėdų su WiFi, bandant RC, routeris po reboot net nesikrovė, gerai, jog galima reset padaryti laikant mygtuką, bei yra toks dalykas NetInstall bet dar neteko bandyti taip atgaivinti.

Labai patiko, jog klaidos greitai tvarkomos, praėjo savaitė laiko ir nauja RC versija, kuri neturi problemų su persikrovimu.

Po kelių ir dar viena RC pasirodė, nors tik vienas pakeitimas buvo.

Man rodos dar reikia palaukti, kol visos klaidos bus sugaudytos, bet bendrai vertinant, neblogas produktas už tokią kainą.

48 komentarai

  • Asus geriau draugauja su visokiais vpn’ais. Arba kitaip įšsireiškus mikrotik nelabai draugauja su openvnp, kas mano akimis jiems minusas.

    Reply
  • O kas tau evaldai neaišku dėl igmp proxy? Jis yra ir bent teoriškai veikia, nors pasikrties ant mikrotiko nelabai išsiaiškinau, ir jis pas mane stovi tuščias

    Reply
    • Dėl telios iptv, kad bent LRT gauti iš jų.

    • igmp proxy visiškai nereikalingas, kad rodyti telia iptv per priedeli.
      Iš esmės pats aprašei kaip reikia daryti, kad vieną portą dedikuoti telia iptv.
      Svarbiausia yra pasigauti telia iptv DHCP ir kai iš jo gausi ip adresą savo priedeliui, tada iptv iškart pradės rodyti. Tad padarius nustatymus įsitikink, kad dhcp jau atkeliauja per atskirą bridge į tą priedelio portą. Priedėlis dhcp reqrestina vieną kartą kraudamasis. Vėliau jis tiesiog pakimba ir bereikšmiškai kažką skaičiuoja (jei negauna teisingo ip adreso)

    • Tai man ne dėl stb reikia, o kad per PC, bent eitų paleisti LRT kanalą.

  • Turiu mikrotik RB951G-2HnD modelį ir naudojuosi skynet iptv per wifi. Be papildomai nusipirkto raspberry+udpxymikrotikiptv klientas, nepavyko niekaip užkurti iptv, kad veiktų nestriginėjant per wifi. Jei žiūrėt iptv per kabelį, tai tada viskas veikia be problemų. 6.41 versijoje mikrotik įgyvendino igmp snooping funkciją – būtina įjungti bridge interface nustatymuose, kai pakuri igmp proxy, jei nenori multicast flood’o į visus įrenginius lan’e, net ir tiem katrie nežiūri iptv. Bent jau skynet iptv pakurti igmp proxy tinka ši intrukcija http://www.technotrade.com.ua/Articles/iptv_config_mikrotik.php Tik nereik /ip firewall filter add action=accept chain=input comment=“IPTV UDP incoming“ disabled=no dst-port=1234 in-interface=ether1 protocol=udp ir quick leave naudoti tik tuomet jei iptv žiūrės tik vienas klientas (jei naudosi raspberry+udpxy, tai ir bus vienas klientas). Pagal straipsnį nustatymų burtai su wi-fi man negelbėjo, tai nieko nekeičiau ir palikau defaultinius, nes vistiek raspberry naudoju.
    Gal ir žinoma informacija…bet kai atsinaujini RouterOS, galima/pageidaujama atnaujinti ir bootloaderį https://wiki.mikrotik.com/wiki/RouterBOARD_Bootloader_upgrade ?
    Pas mane tai kažko letas LAN per wifi. Failai, filmai streaminami ne greičiau nei ~25 mbits/s. Jei filmas sveria ne daugiau 8-9 GB tai dar paveža, bet 4k jau nėr kalbos. Ir labai keista, nes tarkim internetas per wifi sukasi ~80 mbits/s

    Reply
    • Na telios igmp turėtų kažkiek skirtis, bet vis tingiu pasigilinti. Pažiūrėsiu nuorodas paskui.
      O dėl wifi lane, tai man padėjo tik nuo RC kažkokios versijos, dabar dar kelios RC buvo, tai tos problemos neliko apie 44MB/s traukia.

  • Kam reikia ant šito routerio konfigo kaip padaryti, kad per 5portą išeitų Telia IPTV ir per 4 portą taggintas IPV6 ir internetas va konfigas:

    /interface vlan
    add interface=wan name=wan-vlan6 vlan-id=6
    add interface=ether5 name=eth5-vlan6 vlan-id=6

    /interface bridge
    add name=bridge-vlan6

    /interface bridge port
    add bridge=bridge-vlan6 interface=wan-vlan6
    add bridge=bridge-vlan6 interface=ether4
    add bridge=bridge-vlan6 interface=eth5-vlan6

    P.S. 1 portas pas mane pervadintas į wan ir per jį ateina internetas

    Reply
    • Sorry, užsimastęs rašiau apie kažką kitą ir parašiau nesąmonę, beje susitvarkiau pats 😉

  • Klausimas ne į temą: Ką manot apie Ubiquiti EdgeRouter X? Ar labai sudėtinga būtų esant reikalui ateity susikonfiguruoti Telia TV, žaliam? Noriu pasidaryti namuose, kad būtų atskirai routeris ir Wifi, kad tolygiau pasiskirstytų. Daug kas rekomenduoja šitą+UAP AC lite access pointą imt.

    Reply
    • Neteko susidurti su juo, bet kažkodėl manau, kad nebūtų bėdų jeigu vlan palaikymas yra.

  • Sveiki,

    o kaip sukonfiginti „naujieji“ Telios routeriai Technicolor, kad nesvarbu į kur įsmeigtas STB – jis veikia? Bėda ta, kad ant kiekvieno porto turiu po switchą, nes užgyvenau įrenginių; dabar noriu pasikeisti routerį ir nesugalvoju kaip sukonfigūruoti, kad ir internetas būtų visuose portuose ir STB veiktų 🙁
    Bandau sukonfigūruoti Synology RT2600ac routerį.

    Reply
    • Geras klausimas, kol kas nesuprantu, kaip ten padaryta.
      Man rodos jeigu technicolor jų būtų ir switch tada nebūtų bėdų.

  • Mikrotik programinė įranga visuose jų įrenginiuose yra neišbaigta, deja 😀

    Reply
  • Aciu uz puiku tutoriala del Teo Tv. Kiaptik teko padaryti pilna reset’a, tad praverte 🙂
    Del open VPN – jei kas turi normalu manuala su logine seka – pasidalinkit… jau puse metu vis ieskau, bandau, bet nors nusisauk – nepavyksta sukonfiguruoti 🙁

    Reply
  • Susitvarkiau savo Mikrotik pagal aprasyma. Video veikia, bet EPG ne. Ar tau taip nebuvo? Gal gali pasidalinti detalesne konfiguracija?

    Reply
  • sveiki,
    turiu Telia routeri Technicolor TG789vac V2.
    Gal kas zino kaip gauti root access prie jo?

    Reply
  • Gal galetum pasiulyti ka nors alternatyvaus? Sito modelio nelabai imanoma isigyti, nesu tikras koks kitas routeris su gigabit lan tiktu telia iptv

    Reply
    • Net nežinau, berods tplink archer serija, ar kaip ten vadinasi, arba asus, daugiau nelabai, ką žinau 😀 numesk kokius pav, pažiūrėsim.

  • Sveiki,

    Gal kas gales padet, nes savom jegom strigau 🙂 Telia fiber internetas, VLAN IPTV susitvarkiau, viskas ok.

    Pastrigau su portu forwardinimu – atrodo visus variantus isbandziau, bet atrodo vis tiek kreivai veikia (matyt kazko iki galo nepadariau). SItuacija – paforwardinau Plex porta (23900), is namu serverio rodo, kad portas nepasiekiamas. Per tinklapi canyouseeme – irgi rodo, kad neprieinamas. Taciau jei jungiuos is interneto (ne is LAN’o) prie plex serverio – viskas veikia. Su torrentu portu forwardinimu nepavyksta (40000).

    Prisegu nustatymus – gal kas turite minciu ko nepadariau tinkamai? https://pastebin.com/dl/jsPsXJWY

    Dekui

    Reply
    • Aš tai upnp ar kaip ten įjungęs, torrento kliente, tai matau, kad atidaro, o kai pats mėginau, kažkaip įtartinai man ten veikė.

    • Aisku, ta dalyka zinau, galvojau gal imanoma normaliai, paprastuoju budu pasiforwardint. norisi pasileist servisu i isore, kai kreivai veikia nebeina suvest galu kas kaltas 🙂

    • Aš viską per nginx varau, užtenka tik dviejų portų, 80 ir 443, o torrent per upnp.

    • Evaldai, ar tuo iprastu budu (aprasytu straipsnyje) ir pavyksta pasiforwarding 80 ir 443 portus? noriu taip pat pamegint pasileist traefik+letsencrypt, bet su telekominiu routeriu niekaip nepavyko paforwardint 443 porta, del to ir eksperimentuoju su mikrotiku.

    • Plius minus, aš tiesiog susiradau visus cloudflare ip adresus, kad tik per juos galėtų prieiti iki manęs. Pasidariau address list su jų adresais ir jį priskyriau prie tų dviejų atidarytų portų.

    • Jei kam idomu, susitvarkiau panaudojes sia info:
      https://wiki.mikrotik.com/wiki/Hairpin_NAT

      Veikia dabar portu forwardinimas kaip priklauso. Pagaliau patenkintas su routeriu – ir telia veikia, ir greicio 300mbit linijai uztenka, ir konfiginimas nera jau toks sudetingas kaip visur rasoma. super.

    • As WIFI nenaudoju Mikrotiko siuo metu – turiu kitus 2 atskirus AP, pajungtus i Mikrotika, kad normaliai dengtu namus.

  • Užtenka tokios konfigūracijos, kad veiktų Telia išmanioji TV:

    /interface ethernet switch port
    set 0 vlan-header=always-strip vlan-mode=fallback
    set 1 default-vlan-id=6 vlan-header=always-strip vlan-mode=secure

    /interface ethernet switch vlan
    add independent-learning=no ports=ether1,ether2 switch=switch1 \ vlan-id=6

    Kur:
    ether1 – wan
    ether2 – telia tv stb
    Aišku per winbox irgi galima atlikti tą patį.
    Sėkmės!!!

    Reply
  • Po metų šis modelis jau 10 Eur brangesnis (kaip vynas :)) ir, kaip išaiškėjo Mikrotik forume, turėjo (o gal vis dar tebeturi) rimtų problemų su WiFi greitaveika. Šis Mikrotik blynas gavosi šiek tiek prisvilęs.

    Reply
    • Dėl wifi greičio skųstis negaliu 40-50MB/s.

  • Hello Evaldas,

    I’m writing in English because I’m a foreigner in Lithuania. I followed your instructions for router configurations and my setup with a non Telia router works, but I still have some problems (frequent stream interruptions). My understanding is, that Telia IPTV works via VLAN-6. But on my router I see no Multicast (IGMP) traffic, but HTTP traffic. It seems my Telia priedele is connecting to the IPTV service via MPEG-DASH. But Telia claims their IPTV works via Multicast.

    Do you have any information and maybe can get in contact with me via my email? I would really appreciate to get some more info and seems you have really a lot of knowledge in this topic. Labai aciu!

    Reply
    • What router do you have? Yes, works whit multicast udp, using mpegts streams whit encryption.
      For iptv vlan6, but configurations can be a little different on different routers.

Komentarai

El. pašto adresas nebus skelbiamas. Būtini laukeliai pažymėti *

Scroll to Top