Telia IPTV konfigūracija naudojant OpenWRT 1

Telia IPTV konfigūracija naudojant OpenWRT

Tekstas atnaujintas

Kaip ir ant Tomato ir Asus Merlin ar DDWRT reikia tam tikros konfigūracijos ir nustatymų ant OpenWRT

Apie TP-Link

Dažniausiai pardavinėjami TP-Link’ai nepalaiko VLAN konfigūracijos todėl reikia, perrašyti juos į OpenWRT arba LEDE tada atsiranda VLAN’ai ir galima paleisti TEO Gala / Išmanioji / Interaktyvioji TV.

TP-Linkai nėra patys galingiausi ypač modeliai kurių kainos 15-20€, CPU gan silpni (priklauso dar kokia versija, naujesni – galingesni dažniausiai). Per WIFI rodo gerai jeigu nieko nesiunti per LAN ar WIFI. Taip pat labai stipriai smaugia CPU jeigu HD kanalas. Kalbu apie TV žiūrėjimą per PC, su STB problemų nėra.

Routeriai kurie turi atskirą WAN labiau gali patempti TV žiūrėjimą per WIFI ir LAN, teoriškai o praktiškai viskas priklauso, kaip naudosi.

Atskiras WAN tai, kai switche atsiranda papildoma skiltis. Kaip pvz duodu WR1043ND turi atskirą WAN tai per WAN>LAN pralaidumas 250-300Mbps o visi LAN turi 1Gbps. WR841ND neturi atskiro tai jame visi portai 100Mbps.

Per priedėlius rodo tiek su atskiru WAN tiek be jo gerai ir ant didelių apkrovų, nors esu girdėjęs, kad pasitaiko ir trūkinėjimų ant didelių apkrovų nors pats to nepatyriau ant TP-Linkų (o jų turėjau daug).

Kitaip sakant jeigu nesi labai high end user’is kuriam nereikia papildomų programų tiks ir tas routeris kuris kainuoja nedaug.

Apie OpenWRT:

OpenWRT turi labai gerą WIKI kuriame labai daug informacijos. Kiekvienas routeris turi savo aprašymą kur galima surasti daug informacijos. Pvz mums reikia žinoti ar switch’as turi atskirą WAN ar tik CPU nes nuo to priklausys switch’o konfigas.

Routeris kurį turėjau WR1043ND V1.8 turi WIFI hardware bug’ą kuris pasireiškia tik su OpenWRT todėl verta paskaityti WIKI ar tikrai veikia stabiliai su tam tikru modeliu.

Switch su atskiru WAN

Viršuje OpenWRT meniu network skiltyje bus switch.

Kaip atrodo switch skiltis jau su vlan6:

vlan

Taip atrodo switch’as su atskiru WAN tai yra Port0.

Dar vienas pavyzdys su atskiru WAN:

vlan_wrt1900

Kadangi tai dviejų branduolių routeris tai todėl CPU(eth0) ir CPU(eth1) bei atskiras WAN.

Dažniausiai OpenWRT Wiki būna parašyta, kaip sužymėtas switch’as.

Prieš pradedant:

Prieš žaidžiant su switch’u reiktų įsijungti wifi/wlan nes kartais po default būna išjungtas, o jeigu kažką keisi switch’e gali pradingti priėjimas prie routerio, tiesiog negausi IP adreso. Per wlan dažniausiai priėjimas lieka prie LAN ir galima pasiekti routerį per 192.168.1.1

Jeigu nepasieki routerio daryk jam resetą. Dažniausiai būna gale routerio reset mygtukas, ilgai palaikant tai yra apie 10 sekundžių turėtų persikrauti ir atsistatyti.

CPU skiltis visada turi būti tagged.

Jeigu norima per port4 matyti TEO per priedėlį tada ties VLAN1 ir VLAN2 paliekam off ir ant VLAN6 uždedam untagged.

Ties CPU tai yra port0 šiuo atveju ties VLAN1 off, VLAN2 untagged ir VLAN6 tagged

Jeigu norima per 1-2-3 portą LAN’e turėti internetą ties VLAN 1 sudedam untagged o kitur off tai yra ties VLAN2 ir VLAN6.

Taip pat OpenWRT konfigūruojamas per /etc/config/network failą, ten galima atlikti lygiai tą patį ką per WEB. Kai kuriais atvejais ir daugiau.

Panagrinėkim WR1043ND kuris taip pat turi atskirą WAN:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0.2’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’

config interface ‘wan’
option ifname ‘eth0.1’
option proto ‘dhcp’
option peerdns ‘0’
option dns ‘8.8.8.8 8.8.4.4’

config interface ‘iptv’
option ifname ‘eth0.6’
option proto ‘static’
option ipaddr ‘10.10.99.99’
option netmask ‘255.255.0.0’
option gateway ‘10.218.255.254’
option defaultroute ‘0’
option peerdns ‘0’

config switch
option name ‘rtl8366rb’
option reset ‘1’
option enable_vlan ‘1’
option enable_vlan4k ‘1’

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘1’
option ports ‘0 5t’

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘2’
option ports ‘1 2 3 5t’

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘6’
option ports ‘0t 4 5t’

config route
option interface ‘iptv’
option target ‘224.0.0.0’
option netmask ‘240.0.0.0’
option gateway ‘0.0.0.0’

Taigi config interface ‘lan’, lanui duodamas eth0.2 kuris yra VLAN2.

config interface ‘wan’ wan’ui duodamas eth0.1 kuris yra TEO internetas VLAN1

config interface ‘iptv’ o iptv interfacui priskiriamas eth0.6 tai yra VLAN6 ir dar būtinai jam reikia nurodyti IP adresus:

option ipaddr ‘10.10.99.99’
option netmask ‘255.255.0.0’
option gateway ‘10.218.255.254’

toliau eina switch konfigas tai tas pats ką darėme per WEB tik čia tekstas:

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘1’
option ports ‘0 5t’

VLAN1 tai yra internetas jam uždėta ties CPU tagged 5t, 0 tai atskiras WAN.

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘2’
option ports ‘1 2 3 5t’

VLAN2 tai yra LAN  taip pat 5t ir įjungti 1 2 3 portai kurie veiks LAN’e.

config switch_vlan
option device ‘rtl8366rb’
option vlan ‘6’
option ports ‘0t 4 5t’

VLAN6 tai yra IPTV, taip pat 5t ir priskiriamas 4 portas kuris bus IPTV ir rodys per priedėlį taip pat 0t tai yra WAN tagged.

Keičiant network konfigą galima perkrauti su komanda:

/etc/init.d/network restart bet labiau rekomenduojama tiesiog perkrauti routerį.

Po perkrovimo turėtų rodyti IPTV per 4 portą. Per likusius 3 tiesiog veikti internetas.

Panagrinėkim WR841N kuris neturi atskiro WAN:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdcb:3b7a:f9ec::/48’

config interface ‘lan’
option ifname ‘eth1.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘iptv’
option ifname ‘eth1.6 eth0.6’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘10.10.99.99’
option netmask ‘255.255.0.0’
option gateway ‘10.218.255.254’
option defaultroute ‘0’

config interface ‘wan’
option ifname ‘eth0’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘@wan’
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 2 3’

config switch_vlan
option device ‘switch0’
option vlan ‘6’
option ports ‘0t 1 4’

Taigi LAN:

config interface ‘lan’
option ifname ‘eth1.1’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ’60’

Čia skiriasi negu prieš tai buvęs variantas su WAN:  option ifname ‘eth1.1’ prieš tai buvo eth0.1 o čia eth1.1

config interface ‘iptv’
option ifname ‘eth1.6 eth0.6’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘10.10.99.99’
option netmask ‘255.255.0.0’
option gateway ‘10.218.255.254’
option defaultroute ‘0’

option ifname ‘eth1.6 eth0.6’ čia sukuriamas bridge todėl yra eth1.6 ir eth0.6 kartu, prieš tai buvo tik eth0.6.

Swtich atrodo truputi paprasčiau, užtenka tik VLAN1 ir VLAN6

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 2 3’

config switch_vlan
option device ‘switch0’
option vlan ‘6’
option ports ‘0t 1 4’

Apie portus nerašau nes jau turbūt supratai kas kaip.

Abiems routeriamas reikia papildyti firewall konfigą kuris randasi /etc/config/firewall ten reikia pridėti:

config rule
option src ‘iptv’
option proto ‘igmp’
option target ‘ACCEPT’

config rule
option src ‘iptv’
option proto ‘udp’
option dest_ip ‘224.0.0.0/4’
option target ‘ACCEPT’
option _name ‘igmp_udp’
option dest ‘lan’

config rule
option src ‘iptv’
option proto ‘udp’
option dest_ip ‘224.0.0.0/4’
option target ‘ACCEPT’

Kas būna jeigu paslauga neaktyvuota iš TEO pusės?

Pasileidus tcpdump (opkg install tcpdump) su komanda: tcpdump -i eth0.6.

Aišku jeigu konfigūracija bus tvarkinga tai matysi tokį tekstą:

from 5c:b0:66:3b:0b:85 (oui Unknown), length 548
16:31:04.869958 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 5c:b0:66:3b:0b:85 (oui Unknown), length 548
16:31:20.987119 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 5c:b0:66:3b:0b:85 (oui Unknown), length 548
16:31:53.119418 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 5c:b0:66:3b:0b:85 (oui Unknown), length 548

Tada gali kreiptis į TEO jog paslauga neįjungta, aišku jeigu sutartis buvo pasirašyta.

Udpxy

Kas tas udpxy? labiau aprašyta Asus, Tomato, DDWRT konfigo poste.

Norint matyti per PC ar kitą prietaisą reikia įrašyti udpxy. Komandos, kad taip padaryti:

opkg update
opkg install udpxy

udpxy paleidimo komandos:

udpxy -p 4022 -m br-iptv
jeigu nėra atskiro wan

udpxy -p 4022 -m eth0.6
jeigu su atskiru wan

Su OpenWRT nereikia nurodyti -a kaip pvz su Asus ir nereikia -M.

Kad, pasileistų po perkrovimo

Norint paleisti udpxy perkrovus routerį reikia kai ką pakeisti o tai priklauso nuo OpenWRT versijos.
Vienoje versijoje startinis failas randasi /etc/init.d/udpxy kitoje /etc/config/udpxy

Failas kuris randasi /etc/init.d/udpxy ten reikia papildyti:
OPTIONS=“-p 9091 -m br-iptv“ tiesiog kur OPTIONS ten rašoma udpxy komanda.

Kitas failas /etc/config/udpxy
Ten failas turi atrodyti taip:

config udpxy
option respawn ‘1’
option verbose ‘0’
option status ‘1’
# option bind ‘0.0.0.0’
option port ‘4022’
option source ‘br-iptv’
option max_clients ‘3’
# option log_file ‘/var/log/udpxy’
# option buffer_size ‘4096’
# option buffer_messages ‘-1’
# option buffer_time ‘-1’
# option nice_increment ‘0’
# option mcsub_renew ‘0’

Pagrinde option source reikia nurodyti gerą. eth0.6 arba br-iptv priklauso ar yra wan ar ne.

Nepamirštam: /etc/init.d/udpxy enable
Kitaip nepaleis startinio failo.

Išbandyti konfigai ant OpenWRT.

Versijos su kuriomis bandyta:

Ant kai kurių routerių stabiliau veikia su senesnėmis versijomis. Pradžioje siūlau pradėti nuo naujausios versijos o jeigu kažkas veikia nestabiliai, tada galima mėginti senesnes versijas.

Konfigai keliasi į /etc/config aplankalą

TP-Link:

  • WR740N V4.23 
  • WR841N V9.2
  • WR841N V7.2
  • WR841N V8.2
  • WR841N V10
  • WR1043ND V1.8
  • WR1043ND V1.7
  • WR1043ND V2 (tik Chaos Calmer)
  • WDR4300 V1 (su veikiančiu switch driveriu)

D-Link:

  • DIR 825 B1

Kadangi Dropbox jau rašo, kad išnaudotas srauto limitas tai pridedu Google Drive nuorodą į failus.

Visas konfigūracijas perkėliau į savo serverį.

Jeigu turi tam tikro routerio konfigą nepagailėk pasidalinti komentaruose, pridėsiu prie sąrašo. Gali tiesiog copy paste komentaruose.

193 komentarai

  • Turiu ruteri Asus RTN-15U. Jam nereikejo Merlino firmware. Su firmine susikonfiguruoja, kaip esi aprases.

    Reply
    • Man nepatiko originalus todėl rašiau, kad su Merlin, galima ir su originaliu bet man ten kažką pakeitus per WEB viskas nusimuša tai nelabai patiko tai.

  • Turiu network nustatymus TpLinkui1043ND v.2, bet firmwaras tiko tik Chaos Calmer 15.05. Kaip cia prikabint ? Ar tiesiog cia copy paste padaryt ?

    Reply
  • config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config globals ‘globals’
    option ula_prefix ‘fdac:eb6a:4fc2::/48’

    config interface ‘lan’
    option ifname ‘eth1’
    option force_link ‘1’
    option type ‘bridge’
    option proto ‘static’
    option ipaddr ‘192.168.1.1’
    option netmask ‘255.255.255.0’
    option ip6assign ’60’

    config interface ‘wan’
    option ifname ‘eth0’
    option proto ‘dhcp’
    option macaddr ‘xx:xx:xx:xx:xx:xx’ cia savas mac adresas turi but
    option mtu ‘1500’

    config interface ‘wan6’
    option ifname ‘eth0’
    option proto ‘dhcpv6’

    config switch
    option name ‘switch0’
    option reset ‘1’
    option enable_vlan ‘1’
    option mirror_monitor_port ‘0’
    option mirror_source_port ‘0’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘1’
    option vid ‘1’
    option ports ‘0 2 3 4’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘2’
    option vid ‘2’
    option ports ‘5 6’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘6’
    option vid ‘6’
    option ports ‘0t 1 5t 6t’

    config interface ‘vlan6’
    option ifname ‘eth0.6’
    option proto ‘static’
    option defaultroute ‘0’
    option peerdns ‘0’
    option ipaddr ‘10.10.99.1’
    option netmask ‘255.0.0.0’

    Reply
  • Eidavo gerai. Stabilesnis uz v.1.8 Dabar zaidziu su TpLink 4300, gal gausis. Labai panasi sandara i 1043 v.2

    Reply
    • Galvojau pirkti 4300 bet atrodė per silpnas tai Asus teko. Ten Wiki rašo, kad performance krenta wan to lan, tas man netiko.

  • Tiesiog iškilo klausimas, ar pakeitus teo duotą routerį į TP-LINK TL-WR842ND v2 ir jį susikonfrigūravus, teo išmaniaja televizija TV bus galima ir toliau žiūrėt? Su visais archyvais, prasukimais ir kitomis jų siūlomomis išmanios televizijos paslaugomis?

    Reply
    • Taip viskas veiks, jeigu jau rodo per STB tai viskas veiks, nėra jeigu vienas veikia kitas neveikia. Jei kils problemų gali rašyti, padėsiu.

    • Teoriškai neturėtų tikti, čia 50/50 parašyk į skype padėsiu.

  • Siaip idomu ar veikia tas VLAN 6 neuzsisakius paslaugos? O gal uzsisakius pabandymui ir po to atsisakius jis vistiek buna veikiantis? 🙂

    Reply
    • senais laikais, kai tik paleido gala tai sakydavo, kad eina be paslaugos užsakytos bent jau kai kuriems, dabar tai tikrai neina taip, turi būti užsakyta

  • Ar pavyko paleisti and WR941ND? Pas mane netinka joks configas koki radau. Jei pvz surasau sita:

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’
    config interface ‘lan’
    option ifname ‘eth0.2’
    option type ‘bridge’
    option proto ‘static’
    option ipaddr ‘192.168.1.1’
    option netmask ‘255.255.255.0’
    config interface ‘wan’
    option ifname ‘eth0.1’
    option proto ‘dhcp’
    option peerdns ‘0’
    option dns ‘8.8.8.8 8.8.4.4’
    config interface ‘iptv’
    option ifname ‘eth0.6’
    option proto ‘static’
    option ipaddr ‘10.10.99.99’
    option netmask ‘255.255.0.0’
    option gateway ‘10.218.255.254’
    option defaultroute ‘0’
    option peerdns ‘0’
    config switch
    option name ‘rtl8366rb’
    option reset ‘1’
    option enable_vlan ‘1’
    option enable_vlan4k ‘1’
    config switch_vlan
    option device ‘rtl8366rb’
    option vlan ‘1’
    option ports ‘0 5t’
    config switch_vlan
    option device ‘rtl8366rb’
    option vlan ‘2’
    option ports ‘1 2 3 5t’
    config switch_vlan
    option device ‘rtl8366rb’
    option vlan ‘6’
    option ports ‘0t 4 5t’
    config route
    option interface ‘iptv’
    option target ‘224.0.0.0’
    option netmask ‘240.0.0.0’
    option gateway ‘0.0.0.0’

    Tai po visko nebepagauna kompas IP ir niekas nebeveikia, reikia resetint..

    Reply
  • Sveikas , turiu wr1043nd v1.8 openwrt , reikia pagalbos dėl skynet iptv WIFI nustatymu kad galėčiau vienu metu naršyti ir žiūrėti iptv. Kaip dėl to „Bago“ WIFI su 1.8 versija ar ten vis veikia stabiliai? ir tikriausia reiktų pasileisti iptv per udpxy?

    Žinoma jei turi minutėlę laisva ir jei įmanoma.

    Reply
    • Konfigas yra tau tereikia įmesti ir perkrauti, bugas toks, kad kas kažkiek laiko gali tekti routerį perkrauti nes smigs wifi, o toliau viskas normaliai veikia

  • Sveikas,

    O kaip susikonfiguruoti skynet iptv ant wr841nd v.9.0? Dabar reikia ju prietaiso lievo be wifi ir mano wr841. Tad galvoju sukonfiguruoti viska ant w841. O gal tinka gala konfigas?

    Dekui.

    Reply
    • Configas netinka teo, ten yra išvis labai paprastai, kad turi būti multicast funkcija įjungta berods ir viskas, tai gal ten igmpproxy tereikia paleisti.

      Reiktų paklausti vieno žmogaus kur turi skynet, o šiaip gali per skype parašyti, bus lengviau bendrauti.

    • šaunu, kad veikia ir nukreipiau tinkama linkme konfigūruojant 🙂

  • Laba ! kaip sukonfiginti standartini teo ruteri Comtrend Wap-5813n ? Nerodo nei laidu nei per wifi…

    Reply
  • Jaigu as neturiu uzsisakes teo televizijos tai man bet kokiu atveju neveiks ? Turiu tik teo sviesolaidi.

    Reply
  • Sveiki galima matyti teo televizijos nėra užsakyta. Pas manę ji buvo laikinai išjungta paslauga per kompiuteri rodė.

    Tik dabar turiu problema ‘eth1.1’ neina gauti kanalu noriu žiurėti šita programa DVBViewer

    Reply
    • Negalima, anksčiau galėjo dabar neina.
      Apie dvbt nieko nežinau, nes antenos ar kažko tai neturiu.

  • man kompo tik rodo VLC media player per jungus ‘eth1.3 rodo DVBViewer šita programa gera reikia įrašinėti ir ne visada gali namuose o programa junga baigus gali iš junti kompiuteri.

    Kita klausymas kaip dari gyva transliteracija draugams

    Reply
    • žinau, kad galima įrašyti bet aš to nenaudoju nes ir taip teo siūlo archyvo paslaugą.

      nebent visą configą pasakai, kaip darai tada gal kažką patarti galėčiau.

  • ten reikia nuspirti kitus kanalus naudotis įrašai tik dvi savaites. archyvo paslaugąs
    bet dvi savaitės žiaurėti net.

    Apie ta programa DVBViewer daug ja naudoja interneto piratai įrašai laidas

    Tik įdomų kaip daryti transliacijos iš Maršrutizatorius TP-Link TL-WR1043N/ND TV rodytu kitam žmonėms
    tik slaptažodis

    Reply
  • Netiketai pradejo neveikti televija: „Nera rysio su tinklu“

    Viskas veike pora metu gerai, bet dabar nei sio nei sto sitas erroras ir nieko negaliu padaryti.

    Reply
    • Pats konfigūravai? Dabar routerį su openwrt negaliu testuoti pas savęs…

    • Taip.
      Routeris TP-Link WR1043ND V2 – veike normaliai gerus 6-9 menesius su esamu konfigu, pries tai v1 veike gal pusantru metu su analoginiu konfigu. Siandiena pirma karta ismete tokia klaida. Bandziau pajungti v1 (kur tikrai zinau kad veikia) ir tokia pati klaida.

      Istraukiau ir pirelli a125g, orginalu teo routeri, bet ta pati klaida. Tikriausiai is teo puses klaida, o ne confige.

    • Man rodos teks skambinti į teo ir klausti ko neveikia net su jų. Nes man tai veikia viskas su asus routeriu.

    • Paskambinau, pasirodo „priejimas buvo uzblokuotas, del kazkokiu veiksmu“, negalejo paaiskinti kokiu veiksmu, bet uzblokavo. Dabar atblokavo ir viskas veikia. Ziuresiu ar dar ryt rodys 🙂

    • dar taip būna 😀 jei originalus neveikia tai iškart galima knisti protą, bet jeigu sakysi, kad ten kažką pasijungęs tai nenorės padėti.

  • Sveiki turiu modeli tp-link tl-wr1043n/nd openwrt išjunti apsauga.

    Pora dienas mane buvo Teo ir sakė šitas modemas sklaidžia signalas ir sako jus sveikatai kenkia.

    Dėl ko buvo išmanioji TV tripinėja net įranga jungus blogai rodo. O yra mano įrašai visa menu kibinėja o teo sutema nieko rodo blogai.

    Reply
    • Nepagavau minties pilnai.

      Bet kiekvienas routeris skleidžia bangas, plus minus tas pats ir nereikia klausyti ką sako.

      O kodėl tripinėja negaliu pasakyti, gal kažkokias apkrovas gauna ir todėl stringa…

  • tu sakai kažkokias apkrovas bet TEO turi matyti kas blogai net ir su įranga rodo trina. Sako gausi nuolaida 40poc bet jo nereikia TV reikia geros kokybės ne teigimu .

    Reply
  • Ar kam nors meniu blogai veikia. Nes visa mėnesi blogai rodo yra archyvo paslaugąs. Ir sako aš ne su įranga naudoj.

    Reply
  • Sveiki ar jus rodo kompiuteri kanalai nes man ne rodo TV1000 Action TV1000 Premium Viasat Sport Baltic kur gali buti blogai

    Reply
    • Straipsnius pasakityk labiau gal suprasi.
      O šiaip tai ne, nerodo.

  • Kaip keisis konfiguracija jei yra du STB? Vakar siektiek paleisti TV (bet mire internetas), taciau tik ant vieno.
    Bandysiu siandien pazaisti.

    Gal kas galetumete imest screenshotu kaip jusu interfacu konfiguracija atrodo?
    Del Switch, gal zinot ar mirroring nustatymus reikia kazkiek keisti: http://imgur.com/a/xXU2w ?
    15.05.1 @ TP-Link Archer C7 V2 (p.s. per wifi vos 150 Mbps gaunu).

    Reply
    • Kaip ir gerai switch, abu untagged tiesiog turi būti jeigu du stb jungi.

      Del wifi tai noscan komandą susirask internete ant 2.4ghz turėtų padėti.

    • Siaip ne taip pavyko paleisti, bet vargo daug buvo. Reset knopke turi ir WPS feature, tai reset kaip ir neveikia. Kadangi keleta kartu uzsiblokavau priejima, teko per TFTP flashinti. Kompa su ethernet portu siais laikais irgi sunkoka gauti 🙂
      Nezinau kas dabar nutiko, bet kas kelias minutes reikia reconnectinti WAN interfeisa. Go figure.
      O del greicio tai cia ant 5GHz AC toks, einu dar paskaitysiu, gal pavyks kanors rasti.

    • Problema su WAN atsiranda siunciant torrenta ant ~20MB/s. Perkrovus WAN interfeisa veikia, bet letai ir trumpam. Perkrovus ZTE optini keitikli reikalai kiek susitvarko. Ar nebus cia TEO kazka trothtlinąs?

      Cia konfiguracija kuri man suveike: http://imgur.com/a/oKeV5
      Port 1 yra WAN, 2-3 LAN, 4-5 GALA. Portas 6 kiek suprantu yra wireless.

    • Gali būti ir pačio openwrt problemos, nes pas mane patį nėra didelio stabilumo, gali pamėginti https://www.lede-project.org labiau atnaujintas reikalas nei openwrt, configą nuo nulio tai yra keep settings varną nuimti reiktų.

      Pas mane torrentą gali siųsti ant 20-60MB/s per wifi nesvarbu ar tas torrentas turi daug seederių.

    • Bandysiu DD-WRT, ten lyg geriau supportinamas c7v2 modemas.

      Isbandziau 15.05, tai veike dar blogiau. Trunke nera modemo draiverio ir dar visokios problemos.

    • Šiaip openwrt jau miręs reikalas nes developerių nėra, visi pabėgo, siūlau nebent lede development sekti.

    • Hmm. Idomus bugas pasireiske:

      > Tue Aug 16 15:48:17 2016 daemon.notice netifd: wan (12391): Lease of 78.57.219.126 obtained, lease time 300
      > Tue Aug 16 15:50:47 2016 daemon.notice netifd: wan (12391): Sending renew…

      Ir taip kas 2.5 minutes.

      OpenWRT bando gauti nauja WAN IP lygiai uz puses TEO duodamo lango, t.y. vietoj 300 sekundziu, klausia uz 150. Siaip TEO turetu isduoti ji, bet kazkodel atsako tik uz 2.5 minuciu.

      Siaip kalbejau su TEO techniku, tai minejo, jog bridge veikia tik su statiniais IP (o statini IP duoda tik verslo klientams)… Dar bandziau nuklonuoti MAC, bet nepadejo. Hmmz.

    • Zodziu meciau viska, neuzteko laiko iki galo issiaiskinti. Atostogos baiges, tevai reikalauja TV ir stabilaus interneto. Pajungiau gala per TEO ADB routeri, isjungiau wifi ir pajungiau TP Link kaip AP. Uzteks tam kartui. Kitais metais bandysiu dar karta 🙂

  • sveiki,

    TP-Link WDR3600 network config: Gal kas pasakys kas negerai? Dėkui.

    config interface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config globals ‘globals’
    option ula_prefix ‘fd1e:9356:4447::/48’

    config interface ‘lan’
    option ifname ‘eth0.1’
    option force_link ‘1’
    option type ‘bridge’
    option proto ‘static’
    option ipaddr ‘192.168.1.1’
    option netmask ‘255.255.255.0’
    option ip6assign ’60’

    config interface ‘wan’
    option ifname ‘eth0.2’
    option proto ‘dhcp’

    config interface ‘wan6’
    option ifname ‘@wan’
    option proto ‘dhcpv6’

    config switch
    option name ‘switch0’
    option reset ‘1’
    option enable_vlan ‘1’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘1’
    option vid ‘1’
    option ports ‘0t 2 3 5’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘2’
    option ports ‘0t 1’
    option vid ‘2’

    config switch_vlan
    option device ‘switch0’
    option vlan ‘3’
    option vid ‘6’
    option ports ‘0t 4’

    Reply
    • Vlan 3 nurodo automatiškai sukūrus Vlan 6 per web gui, bet TEO IPTV trūksta IP priskyrimo..

    • Kai interface pridedi tai ten priskiri tą ip. Čia nebent jei udpxy nori matyti, o vlan6 padarius iškart per stb turi rodyti.

    • Nemanau, gali mėginti Network dalį, jei neveiks po restart tai reset su mygtuku padaryti reiks.

  • turiu tp-link archer C2 AC750, ar reikia keisti kazka, kad geleciau jungt TEO TV ir neta vietoj senojo ju Speedtouch 585?

    Reply
  • Ka, jei imanoma suzinoti konkreciau? Nesu specas, bet meginti nieks nedraudzia. Is teo gaunu 100Mb sviesolaidi, su senuoju marsrutizatoriumi tv veikia be preikaistu, bet wifi nuluzineja pastoviai kiekviena diena, uzkniso perkrauti…

    Reply
    • Viskas šiaip aprašyta, jeigu tingi galvoti į skype parašyk, šone yra mygtukas skype.

      Realiai openwrt žiūrėt ar veikia, arba ant originalaus gal net jeigu tas naujas dizainas web interface.

    • Sveiki, koks jūsų skype Evaldai? Reikia pagalbos su open-wrt ir telia tv.

    • Sveiki,
      naudoju TEO GALA. Ar būtų galima TEO maršrutizatorių ADBB jungti ne tiesiai prie šviesolaidžio adapterio, o per mano maršrutizatorių TL-WR841N (prie jo dar jungčiau PC).
      Ačiū.

    • taip, perrašyti į lede reiktų, tada config pakeisti, bei teo adb paderinti.

    • Būčiau dėkingas už šiek tiek platesnį paaiškinimą, nežinau, kas yra „lede“?

  • Sveikas, mačiau, kad esi isgyjęs Asus WRT1900 ACS. Gal galėtum pasidalinti vlan konfiguracija ant OpenWrt? Pas mane yra WRT1900acs V1 ir niekaip nepadarau galos TV ant 3 ir 4 portu.

    Reply
    • Susimaišiau aš jau tuose pavadinimuose. Manasis ruteris pradejo durniuoti, pametinėti 2.4GHz tinklą, rebootintis neprašytas, kartais išvis atrodo išsijungia viskas ir net nepersikrauna. Tai nusprendžiaų, įsipūst openwrt pažiurėti ar nebus geriau, bet nesigauna man vlan sukonfiguruoti. O ir switch menu turėjau susikurti, nes nebuvo susipėtus firmwara kažkodėl. o kai susikuriau man jis visiskai kaitaip atrodo nei tavasis. Kame kampas galėtų būti.??

      Mano switch configas is /etc/config/network atrodo taip:

      konfigą radau, openwrt forume ieškodamas kaip aktyvuoti switch menu:

      config switch
      option name ‘switch0’
      option reset ‘1’
      option enable_vlan ‘1’

      config switch_vlan
      option device ‘switch0’
      option vlan ‘1’
      option ports ‘0 1 2 3 6’

      config switch_vlan
      option device ‘switch0’
      option vlan ‘2’
      option ports ‘4 5’

      Šitą dalį pats darašiau, nes man kaip ir reikalingas 6vlan kad Telia IPTV veiktų:

      config switch_vlan
      option device ‘switch0’
      option vlan ‘6’
      option ports ‘0 1 5t’

      portų išsidėstyma ėmiau, iš https://wiki.openwrt.org/toh/linksys/wrt_ac_series.

    • Pas tave kur interfaces ties br-lan rašo lan1 lan2 lan3 lan4? Gali būti, kad blogą versiją įrašei, nes ten ant naujų kvailų pakeitimų buvo.
      Switch dalies aktyvuoti ar kažką panašaus nereikia, iškart turi būti.

    • man toje lenteleje viskas issidesto taip:

      Lan0 lan1 lan2 Lan3 Lan4 CPU Lan6.

      Tai suprantu kad Nuo lan0 iki Lan3 yra portai 4-1. Lan4 yra wan, Lan6 yra internal CPU.? As ka tik susipuciau DDwrt, bet nepatinka jis man, tai tuo susipusiu OpenWRT atgal ir nusnipinsiu tiksliai nuotrauką.

    • Pas tave bloga versija, tai ten nesąmones padarė su switchu, rašyk lede vietoj openwrt berods dar nėra tos nesąmonės, kai rašys ne lan1 lan2 ir pnš, reiškia tinkama versija jog rodytų.

    • Lede tai openwrt kopija, viskas taip pat, tik kad openwrt nelabai vystoma daugiau…mėgink kelias versijas kol bus normalus switch. Nes kitaip aš nežinau kaip paleisti.

    • Susipučiau, Switch atsirado ir viskas atrodo taip pat kaip ir pas tave nuotraukoje. Dabar klausimas:
      Lan1 ir Lan2 yra 3 ir 4 portai ant ruterio?

    • Ant taviškio gali būti atvirkščiai užvadinti 🙂

    • Padarau identišką konfigą kaip pas tave, rebootinu ruteri, ir wsio. Wifi rodo, kad yra, bet nera neto. Bandau, jungtis prie 192.168.1.1 neleidžia. hmm cota ne tak…

  • Tavo Konfiga sumetus pas mane, as kai rebootinu, ruteri, man viską nukilina, ir kai suvedu 192.168.1.1 mane prileidzia tiesiai prie zte modemo optikos…how I dont know….

    Reply
  • TEO GALA maršrutizatoriaus (ADB) interneto išėjimą paduodu į du kompus per TL-WR841.
    Viskas veikia, išskyrus ryšį tarp TV ir kompų. Jungiant kompą tiesiai prie ADB, ryšys yra. Kaip reikėtų konfigūruoti?

    Reply
    • Nelabai supratau, kaip jungi viską, galima ir wr841 naudoti kaip pagrindinį o adb kitiems kažkur paduoti, bet reik nustatymus tvarkyti.

    • ADB naudoju kaip pagrindinį, prie jo jungiu TV, o jo internetinį išėjimą paduodu į WR841 WLAN įėjimą, o kompus jungiu prie WR841 išėjimų

    • Labiau paaiškink tą ryšį dėl tv ir kompų, nes nelabai pagavau kampą.

    • Smart TV prijungtas prie ADB, veikia normaliai, bet noriu matyti per TV ir įrašus iš kompo. Jei kompą prijungiu prie ADB tiesiai – viskas OK, o jei per WR841 – kompas ir TV vienas kito nemato.

      (bandžiau čia įkelti schemą, bet tokia galimybė nenumatyta :))

    • Turbūt dėl DHCP nieko nedarei? Nes nemato tiesiog vienas kito nes abu kuria savo atskirus tinklus.

    • Kai DHCP išjungi tai į antrą routerį kuriame DHCP išjungtas lan kabelis ne į wan eina o į lan. Daugiau problemų kodėl galėtų būti nžn.

    • Būtent to ir tereikėjo, išjungiau DHCP, permečiau kabelį iš WAN į LAN portą ir viskas veikia. Didelis ačiū!

    • Pats sukau kažkada galvą kodėl neveikia tai tas dalykas padėjo 🙂

  • Laba
    įsigijau routerį WRT1900ACS (v1), įrašiau LEDE ir noriu sukonfigūruoti, kad Telia IPTV veiktų per 4-ą LAN portą.
    Skaičiau skaičiau šį postą ir sukurpiau tokį network failą: https://pastebin.com/ZQkVmpsW

    Deja jį galėsiu išbandyti tik po poros savaičių, bet galvojau, kad galima gal dabar pradėti rengtis ir paklausti, ar nėra kažkokios akivaizdžios klaidos?

    Reply
    • Pagaliau galėjau išbandyti IPTV per routerį. Atrodo, kad viskas gerai, bet vistiek yra kažkoks kabliukas. Jei jungiu 1 priedėlį tiesiai į routerį, viskas veikia gerai, bet jei jungiu per switch (namie 3 TV), vaizdas ir garsas pradeda striginėti, priedėlis rašo, kad yra ryšio problema, vėliau transliacija atsinaujina ir vėl stringa. Kažkokio didelio srauto per switchą nėra, nes visi aparatai išjungti tuo metu. Kame galėtų būti problema?
      Jei naudoju telia routerį, jokių problemų su switch nėra net transliuojant per 2 TV.

    • Turėtų būti switch problemos, kad udp normaliai nepraleidžia, o ans mandras ar tas kur įstatai laidą ir viskas?

    • Iš kažkur stovi HP 1810-8G. Čia gal per protingas, reikia paprastesnio?

  • siandien i tp-wr841n imeciau tavo duotaji network faila. Niekaip negaliu prisijungti prie interneto. Senas zebra pdg a4001n routeris veikia puikiai. Kad nors paprastas internetas be iptv pasileistu ant tp-linko, bet deja….

    Reply
    • galbūt naują versiją kokią routerio turi, parodyk kaip atrodo switch dalis originaliai, print screen gali.

    • routerio versija- v12.0. Idiegta LEDE 17.01.2. Kazkokiu uzluzimu ar kitu problemu nepastebejau. Vakar bandziau su routeriu tp-wr740n v4.28 su openwrt 15.05.1. OS darbe nukrypimu irgi nepastebejau. Bet i interneta nepapuolu kazkodel. As tik pakeiciu network faila arba network ir firewal i tavo serveryje duotus. Viskas veikia, bet prie interneto nesijungia. Gal dar kazkokius nustatymus reikia pakeisti? Kaip ideti „print screen“? Nematau tokios opcijos.

    • Jeigu nėra interneto tai tik switch dalies problemos. Kai galėsi parašyk į skype: eddas123 padėsiu, bet ne šį vakarą.

    • pamiršau, kad čia be atskiro wan, tai dar reikia žiūrėti ir interfaces dalį, realiai viską reik pačiam sudėti per web nuo nulio, kad tikrai pradėtų veikti o ne config dėti.

    • Padėsiu jeigu kokią dieną parašysi į skype, nes nepatogu taip aiškint…

    • Labas, jeigu keiti TEO router’į į tp-wr841n, tai kaip šį TP-Link įkiši ADSL jungtį??? (skirtumas http://vanilla.co.za/images/ethernet_vs_telephone.jpg ). Antra, revizijos dažniausiai skiriasi, ypač V12 modelio, nes jame jau kitas SOC (kitas cpu, switch), tai darydamas pagal internete esančius tik užbrikinsi router’į, neteisingai pasirinkti portai (iface) dėl to ir nepatenki. Ir man įdomu žinoti iš kur gavai v12 modelį, nes visi Lietuvoje pardavinėja seną 🙂

    • siek tiek pavirsutiniskai apsisvieciau ieskodamas googleje man reikalingo varianto. Pas mane jungtis ne telefonine, o dsl. Is telios ateina kabelis, jungiasi i spliteri, kuris atskiria dsl ir telefono signalus. Spliteryje yra atitinkamai 2 kistukai: dsl ir telefonui. Dsl kistukas yra toks kaip tavo paveikslelyje, tik su 4 laidais. DSL/LAN laidu kontaktai pagal technologija atitinka: rj45 8p4c (ir 8p8c) atitinka rj11 6p4c (pridedu paveiksleli http://i.ebayimg.com/images/g/TjoAAOSw-nZTnEXj/s-l500.jpg ); taip pat atitinka mano atveji 4p4c. Netgi 4p4c kabelis puikiai tinka i 8p8c lizda. Visdelto pas tp-wr 740n is 8 galimu kontaktu yra 4 ir isdelioti kitaip ( http://luinys.org/downloads/tp-wr841n.v12.0/100ba.se-tx.png ). Cia jau reiketu nagrineti toliau ir daryti kazkoki adapteri. Pas tp-wr841 yra visi 8 kontaktai, vadinasi teoretiskai galetu mano dsl veikti. Pirma turiu pamineti, kad zebros pireli routeris rodo tokia naudinga info: adsl2+, prisijungimas per „routed ETHoA“ (ethernet over atm) protokola, anex M, VPI 8, VCI 35, encap LLC. Tuom remdamasis dariau paieskas. Turiu pasakyti, kad lietuviskuose puslapiuose beveik nieko nera. Arba per mazai zmoniu domisi technika, arba nemegsta rasyti, arba dar kas nors… Visdelto radau kaika idomaus veiname forume. Vaikinas adsl norejo prijungti prie nuosavo routerio (nebepamenu nei firmos nei modelio). Jis panaudojo originalia routerio progr. iranga. Ten po daugelio bandymu prisijunge per „1436 Mer“ naudodamas mano auksciau surasytus duomenis. Toliau radau angliskuose openwrt forumuose, kad kazka panasaus i ETHoA pas openwrt daro PPPoA, bet dar reikia manualiai (per config faila) sukonfiguruoti dsl ir bridge. Kitas tokiu atveju naudojo PPPoE kazaip su ATM ir dsl, bei taip pat neapsiejo be config failo rasymo. Isvadoje buvo parasyta, kad openwrt is saves (per web UI) nepalaiko ETHoA, bet rasinejant config failus ta padaryti iseina. Man, pavirsutiniskai nagrinejant, sito pasirode per daug ir as nusprendziau mesti ta reikala. Tad as nuvykau i telia salona pasiklausineti. Issiaiskinau, kad kaimo vietovese adsl gerinimas nenusimato, kaip ir sviesolaidzio tiesimas. Konkreciai musu sutartis numato max dsl greiti iki 8mbps, routeris rodo vidutiniskai 1,5mbps, ta pati ismatuoja online speedtestas. Realus nusikrovimo greicio vidurkis vistiktai yra apie 200kbps. Taigi, telia pasiule 2 sav. pabandyti 4g lte „connect 200“. Dave atitinkama routeri su labai mazais 2 antenu iejimais ( crc-9 ). Taciau butent musu sodyba randasi, jei galima taip pavadinti „elektromagnetiniu bangu duobeje“ ir mobilus rysys traukia silpnai ir tai tik vietomis. Zodziu, antpalanges lte man trauke, pagal speedtesta, 5mbps, taciau nusikraunant failus veike labai nestabiliai ir pakildavo max iki 350 kbps, o krisdavo staigiai iki 0 kbps. Tada as youtubeje radau kaip paprastai is drato ir metalines ploksteles pasidaryti 800mhz kryptine quad antena. Kadangi crc-9 kistuko neturejau, o jo centrine skylute labai maza, tai toje vietoje panaudojau drata is dratinio sepecio. Rezultatas buvo puikus. Speedtestas parode 13mbps greiti, nusikrovimas vyko stabiliai, vidutiniu 1,6mbps greiciu. Tai 8 kartus greiciau negu mano dsl. Beje, realu nusikrovimo greiti nurodau ta kuri rodo nusikrovimo programa jdownloader2. Nezinau, kaip pageretu 4g lte greitis iskelus mineta antena i lauka, ant stogo. Bet tai darysiu po metu, per kitas atostogas. Isviso esu sugalvojes, savadrbe namu wlan antena iskelti ant stogo taip kad geras wlanas butu visoje sodyboje (o jos plotas nemazas). Kita vasara…
      Na, o tp-wr841n v12.0 pirkau Telsiuose, TOPO centre. Idomu, kad tiek openwrt, tiek jos atmainos, bei originali firmware is gamintojo puslapio yra siuloma tik v11 ir v13 versijoms, o v12 nera. Visi sako, kad v12-am routeriui reikia instaliuoti v11 firmware. Tiesa, wr841n sugadinau. Wr740n is openwrt (lede) i originalai firmware atstaciau per web ui, pervadines bin faila. Wr841n is openwrt (lede) paverciau i gagoyle-router, o kai is cia bandziau atstatyti originalia firmware kazkas ivyko ne taip. Dabar routeris uzsikraudamas ijungia visas lamputes ir po keliu sekundziu gesta, vel kraunasi, vel visos lemputes… ir taip be galo. Bandziau ipusti originalu bin per tftp serverio programa tftp64, sujunges routeri su pc per lan jungtis, bei nustates pc static ip 192.168.0.60 (berods taip). Routeris firmware speja pasiimti 100% is tftp serverio, bet viskas islieka po senovei. Galkas zinote kaip sutvarkyti wr841n routeri? Tiek siam kartui 🙂

    • Reiks to usb laido, dabar nepamenu jo pavadinimo, kur jungiasi prie pačios plokštės, o tada per terminalą susitvarkai pagal wiki.

    • Kaip Evaldas rašė, tau reiks USB To RS232 TTL kabelio http://www.ebay.com/itm/USB-To-RS232-TTL-UART-PL2303HX-Auto-Converter-USB-to-COM-Cable-Adapter-Module-/201539573206 Bet tam reiks ardyti jį, tai prarasi garantiją, jei ji vis dar galiojanti.
      Kas dėl ADSL ir LAN jungčių, tai čia jau per daug nusigalvojimų, neveltui ADSL modemai būna, routeriai neatpažįsta jų protokolo, dėl to tau ir nieko nesigavo. Jei taip paprasta būtų, tai senai ebay mėtytųsi adapteriai…. Kas dėl ADSL2+ protokolo, tai rodos jam reikia PPPoE kiek pamenu, bet dar reiktų pasijungti savo seną D-Link modemą-routerį.
      O tau tam reikalui reikėjo iš šių http://www.tp-link.com/sa/products/list-15.html

      Kas dėl 4G, tai Telia šiaip siūlo daug kur hibridinį… (ADSL2+ ir 4G vienu metu) O anteną pirk iš kinų, pigiau atsieis, nes Lietuvoje užlenktos kainos, nebent dar pasiskambinti į Erksa, nes labai gerą produkciją pardavinėja ir žino apie tai beveik viską. Aišku spėju ten kaina atitinkama…

    • ta usb-serial kabeli nesunku pasidaryti paciam. Instrukcija kaip unbrick tp-link radau cia (nors kalbos nesuprantu, bet is vaizdu viskas darosi aisku kas ir kaip) https://www.youtube.com/watch?v=-ufRivQF4_I . Del dsl man kazkaip ne i galva neatejo, kad mano turimi routeriai neturi dsl modemo. Turimas zebros routeris naudoja adsl2+ su anex m (gal tinka ir kitoks anex- nezinau), zebros prisijungimo protokolas ETHoA. Si protokola, pagal mane, atitinka PPPoA (openwrt turi atitinkama paketa) arba kaip viename forume radau- 1432 mer (jei gerai pamenu). Siaip, tai su kabeliu rj11 4p4c eina prisijungti prie rj45 8p8c, 8p6c, 8p4c, jei abiejuose galuose isdeliojimas dsl jungciai, bet jei nera dsl modemo, tai, suprantama, kad nieko neiseis. O antena tai pasidariau pats, kazkur tai trigubai padidino greiti dar kambaryje. Iskelus ant namo stogo tureciau dar geriau. Pagal sita pasidariau mineta 800-850mhz antena https://www.youtube.com/watch?v=Vd96UAjNsgs Reiks kadanors pabandyti dar su bi-quad antena ir aukstesniuose dazniuose, kaip cia https://www.youtube.com/watch?v=ZCYXnm1JhSg . Priklausomai nuo siuntejo dazniu, antenos ismatavimai skiriasi (reikia suzinoti kokiu telios dazniu mano vietoveje geriausias butu internetas / kokiais dazniais telia isviso transliuoja 4g lte). Priminsiu, kad kuo aukstesnis daznis, tuo didesnis greitis, bet tuo paciu rysiys jautresnis trikdziams ir mazesnis pasiekiamumo atstumas. Minetu antenu matmenis pagal norima dazni galima pasiskaiciuoti cia: http://buildyourownantenna.blogspot.de/2014/07/double-biquad-antenna-calculator.html Praktiskai, si informacija apie antenas labiau naudinga tiem, kurie gyvena nutole nuo miestu, retransliavimo bokstu ir pan.

  • Sveiki, turiu routeri be atskiro wan, kaip per per web sudeti interfeisus, noriu pasileisti Gala IPTV

    Reply
  • Sveiki,
    Turiu TL-WR841N V9. Kokiu būdu konfiguracinius failiukus sukelti ?

    Reply
    • Patogiausiai su winscp, jeigu neveiks, po perkrovimo, tai bent wifi pažiūrėk kad būtų įjungtas ir galėtum pasiekti routerį, arba palaikyti gale mygtuką teks kad viską atstatytų.

    • O gal yra koks aprašymas, ką konkrečiai reikia daryt? Neesu labai pažengęs šioje srityje. Labiau user level

    • Pats tokio nesu parašęs kaip tai padaryti, tik ant asus kur yra pamoka, kažkiek užsiminiau. Jeigu gali parašyk į skype: eddas123 turėdamas laiko padėsiu.

  • Failiukus sukėliau į routerį bet STB negauna IP adreso. Kalba eina apie WR841N/ND V9

    Reply
  • Sukonfigūravau Xiaomi WiFi Mini routerį pagal šitas instrukcijas, sakyčiau, beveik be problemų! 🙂

    1. Network/Switch ir Network/Interfaces skiltyse sukūriau VLAN 6 per GUI, ir jam priskyriau autoriaus nurodytus static IP address, gateway, netmask.

    2. Perkrovus routerį, set-top-box nepagavo IP adreso, tai ranka reikėjo prirašyti į network config:

    option defaultroute ‘0’
    option peerdns ‘0’

    Viskas pradėjo veikti 🙂

    3. Tada sekė firewall konfigūracija, kurią suvedus ir restartuojant firewall, beje, gaunamas warningas, kad kažkurios taisyklės „refers to not existing zone ‘iptv'“. Tą išsprendžiau per GUI, Network/Interfaces/IPTV [Edit]/Firewall Settings, ten sukūriau firewall zone ‘iptv’. Perkrovus firewall, warning dingo, viskas ir toliau veikia.

    Reply
    • Bandžiau ir LEDE, ir OpenWRT, 15 versijos buildus, taigi:
      – OpenWRT veikė lėtai (bet užtikrintai?) – wifi klientui atiduodavo max. 65-75 mbps, nors per LAN kabelį arti 100 mbps, kas pas mane yra max greitis pagal planą
      – LEDE wifi veikė greičiau, bet kartais routeris pakibdavo, parsisiuntus kelių GB failą. Padėdavo tik išjungimas iš elektros tinklo.

      Galų gale apsistojau ties outdated, bet Xiaomi optimizuota PandoraBox versija iš čia: http://en.miui.com/thread-208652-1-1.html
      Užsiflashinus firmware, Network/Wifi konfigūracijoje dar pakeičiau country code iš CN į LT: veikia greitai, stabiliai, ryšys stiprus, nors routeris uždarytas drabužių spintoje ir signalas turi pereiti vieną ar dvi sienas.

    • Galvoju gal atsinaujinti, bet tie xiaomi tik su 100Mbps ir mažai portų.

    • Tikrai taip, bet gigabit routeriai kainuoja kokius 3x daugiau. Portų trūkumą išsisprendžiau su papildomu 4 portų switchu, jie abu kartu užima daug mažiau vietos negu Telia siūlomas routeris.

    • Jei nereiktų tos telios iptv, būtų lengviau…o dabar galvos skausmas, kad ir kaina kosminė nebūtų 😀

  • Sveiki padariau ant routerio wr1043nd kaip cia buvo parodyta tik pas mane CPU eth1 nera (http://i.imgur.com/HlsVpQ7.png) ir dabar per 1 ir 2 televizija rodo, bet interneto nera ir neina ieiti i routeri, gal galit padeti?

    Reply
    • Blogai būsi sudėjęs untagged. Tokiems dalykams patarčiau Wi-Fi palikti įjungta nes keičiant nustatymus, routerį galėsi pasiekti per Wi-Fi. O dabar jeigu negali per Wi-Fi, tai tiesiog reset darai routeriui, gale laikydamas reset mygtuką.

    • 4 portas nerodo? kokį ip pasigauna jeigu kompą pajungi?

  • Ar teisingai suprantu, kad TEO kažką pakeitė prieš metus ar du ir dabar nebegalima per udpxy žiūrėt? Koks tada veikiantis playeris yra linuxui?

    Reply
    • Viskas tas pats, tik vietoj visų kanalų rodo tik LRT, kiti koduoti.

  • Atsitempiau namo routerį TP-link archer c1200. Matau 4 LAN ir 1 WAN portą (jei gerai suprantu). Ir dabar turiu galvos skausmą kaip per jį paleisti Gala TV. Prisijungus prie routerio per naršyklę randu begalę nustatymų (visokie LAN, VLAN, DHCP, ipv6 ir t.t.). Prisipažinsiu, kad čia man tamsus miškas. Taip pat yra IPTV/VLAN skiltis. Gal čia yra raktas? Bandau ieškot atsakymo, tačiau nesėkmingai. Pvz., Reikalauja suvesti kažkokius VLAN ID, nustatyti PRIORITY. Kas čia per daiktas? Jei kas nors yra paleidę GALA su standartine routerio programine įranga, gal galite sufleruoti, kaip tai padaryti? Ar su standartine visgi čia nieko nesigaus?
    Routeris šitas https://www.tp-link.com/uk/download/Archer-C1200.html#Firmware
    Ačiū

    Reply
  • Sveiki, situacija tokia kad i namo rusi ateina sviesolaidis, jis konvertuojamas i tinkla, tada stovi routeris. Namas turi du butus, 1as butas naudoja tik interneta, 2asis nori interneto ir televizijos. Kiek kabeliu reik tempti i antra buta is rusio norint ten statyt routeri ir turet interneta bei televizija?

    Reply
  • Sveiki, gal galit paaiskinti ka ne taip darau? Bandau konfiguruoti per web, routeris tplink archer c50 v3. Jei nekeiciu eth1 ir eth2 vietomis, sudedu tik vlan6, tuomet jei prie switch vlan6 zymiu wan tagged, tv per stb rodo bet nera interneto. jei vlan6 wan portas off – tuomet veikia internetas, bet nerodo tv. jei pagal aprasyta konfiguracija sukeiciu eth1 ir eth2, tuomet prie interfeisu wan neprisiskiria ip per dhcp, rodo tik televizija o internetas neveikia visai

    Reply
  • Kodėl būtent 10.10.99.99? Ir subnetas kitoks, ir gateway… Netinka DHCP šitoj vietoj? Straipsnyje apie Mikrotik tai nematau, kad būtų kur nors statinis IP uždedamas – kodėl ten kitaip?

    Reply
    • Čia kai buvo galima žiūrėti per PC reikėdavo. Dabar kai apsaugos sudėtos, tai nematau reikalo taip daryti…realiai užtenka tinkamo vlan ant porto ir rodys priedėliai.

    • Ačiū! Pasidariau ant TL-WR941ND v3.2, mačiau žmogus klausė. Jei kas dar ieškos per google, tai ten situacija tokia, kad OpenWRT ant to routerio naudoja DSA vietoj swconfig, todėl „standartinė“ konfigūracija netinka. Standartiniam config yra interface su ‘lan1 lan2 lan3 lan4’ – ten norimus TV portus išimam, tada padarom lygiai tokį patį interface, tik čia paliekam tik norimus TV portus ir dar pridedam wan.6 – tai užtagina wan portą, o kiti ten išvardyti portai lieka untagged. Jei teisingai supratau, tai su šita komanda galima net ir kelis skirtingus VLAN ID naudot ant to paties interface, pvz taginti lan4 su kokiu nors VLAN ID 10, o wan palikti su VLAN 6 – tik nežinau, kam to gali reikėti.

  • Sveiki visi. Tikiuosi puslapis dar gyvas 🙂

    Vakar įsigijau TP-Link AC1750, nes Technicolor ryšys miegamajame, tiesiog, po truputį žudė (1Gb/s internetas veikė 5 Mb/s sparta (kartais ir mažiau) – t.y. vos YouTube’ą krovė).

    Pajungus TP-Link’ą skirtumas akivaizdus – interneto greitis miegamajame ~300 Mb/s – puiku!.. beveik. Telia televizija nebeveikia 😐 (Aišku, aš tai žinojau prieš naują maršrutizatorių pirkdamas).

    Taigi prisijungiau prie TP-Link’o „Admin panel“ ir ten „Network“ dalyje yra „IPTV/VLAN“ nustatymai. Įgalinau „IPTV/VLAN“ ir „LAN4“ jungtį paskyriau televizijai.

    Dabar į šią jungtį pajungus Telia priedėlį televizija veikia TIK tuo atveju, jei į TP-Link’ą internetas pajungtas pro originalų Telios Technicolor maršrutizatorių. Jeigu internetą pajungiu tiesiai į TP-Link’ą pats internetas veikia tol, kol nėra įjungtas televizijos priedėlis – tik priedėlį ijungiu, dingsta internetas ir televizija neveikia.

    Gal kas susidūrėte su kažkuo panašaus ir turite sprendimą? Skaičiau čia komentarus, kad OpenWRT nebėra naujinamas (nors iš tiesų softo perrašymo norėčiau visai išvengt jei tik įmanoma).

    Dėkui už pagalbą.

    Laurynas

    Reply
    • Puslapis dar gyvas 😀

      Screenshot padaryk tos dalies „Taigi prisijungiau prie TP-Link’o “Admin panel” ir ten “Network” dalyje yra “IPTV/VLAN” nustatymai. Įgalinau “IPTV/VLAN” ir “LAN4” jungtį paskyriau televizijai.“

      Ten reikia, kad 6 būtų parašyta ties iptv. Kiek pamenu įmanoma ir su originaliu.

    • https://imgur.com/JqJoVfk

      lyg ir taip, bet gali kažkas dar skirtis 😀 gali internetas dingti arba tik tv rodyti, tada dar reiktų keisti, ir būtinai junk kaip pagrindinį ne nuo telios routerio.

    • https://imgur.com/ytOn2k9

      mėgink dar taip, realiai iptv6 tur būti, internet kaip ir 1 o lan 2, bet čia žiūriu tik internet ir iptv prašo 😀 realiai turi pažaisti su nustatymais, nes tplink senai nebeturiu ir nežinau, kaip tiksliai dėliojasi viskas.

    • wohoo. iš 15-to karto pavyko 😀

      jei kam reikės: https://imgur.com/a/5kMu2OL

      Jei telefoną naudojat, tai gali būt, kad tas 22 ten jums netiks. Tuščio palikt neleido, tai bet ką įvedžiau 😀

    • Šaunu, kad pavyko. Paskutinis kur disable palikai, kaip suprantu jog vidiniame tinkle veiktų udp. Bet ten realiai tik lrt įmanoma žiūrėti.
      Vėliau pridėsiu manau prie įrašo.

  • Sveiki, buciau dekingas jei kas geletu padeti sukonfiguruoti TP link Archer C2300 kad galeciau ismesti duota teo routeri kuris stovi dabar kaip bridge.

    Reply
    • Laurynas is da king pagal jo foto viskas eina suuuper

  • Sveiki,
    Šiandien įsirašiau OpenWRT savam TP-Link Archer C2 v3 AC900 kad veiktų IPTV, bet gali tiap būti, kad softas kerta per interneto greitį? Mano internetas 1Gbps o dar vakar naktį su gamykline OS dariau speedtest ir greitis buvo 820Mbps ir 902Mbps upload’as o po to kai įsirašiau OpenWRT atlikau speedtest ir 416Mbps beik 299Mbps upload kame čia bajeris gali būt? tipo jis kerta per greitį?

    Reply
    • Taip, kerta per greitį jeigu nėra normalaus hw palaikymo o dažniausiai taip ir būna, iki 100Mbps bėdų nėra, o toliau prasideda…
      Todėl mečiau openwrt ir dabar naudoju MikroTik.

    • Tik vienoje vietoje apie Vlan rašoma? openwrt tikrinai ar eina paleisti?

    • Na as tik vienoje vietoje radau vlan nustatymus, ir tai blokuotus (1-7). openwrt nebandziau, nes neradau jam softo. Kokiu zingsniu reikia imtis?

    • O koki openwrt galeciau naudoti? Nes panasu, kad visi nutilo, niekur nerandu pagalbos?

  • O tai kam nors pavyko pasileisti Internetą+IPTV ant tų pačių portų? Taip, kaip veikia su „nuostabybiškais“ Telia (Technicolor) routeriais. Ar jie dėl to ir „nuostabybiški“ (lužinėja, praranda ryšį ir pan) būtent dėl to, kad softas primaklintas? 🙂

    Aš dar iki Telia įsivedimo turėjau gan ne pigų Asus RT-AC68U routerį. Ir kai sužinojau, kad Telia bruks savo routerį, jau buvo per vėlu atbulinį jungt.. teko su liūdėsiu dėt Asus’ą į stalčių. Iš pradžių keletą dienų laužiau Asus’ą – bet ne kažkas pavyko. Paskui mečiau ir bandžiau susitaikyti pusę metų su Telia routerių. Tačiau stabilūs interneto dingimai galutinai nusibodo, tai bandau vėl laužyt nesėkmingai..

    Dedikuojant vieną routerio portą televizijai – televiziją veikia gerai, bet internetas – neveikia. Pas mane iš to porto eina laidas iki switch’o, iš kurio „maitinimą“ ne tik televiziją. Kitaip tariant toks sprendimas nelabai tinka – nebent laidus pervedžiot. 🙁
    Bandžiau prišnekinti Telijos technikus, kad padėtų už papildomą mokestį, bet sako be šansų arba rizikingą routerį sugadint, nes reikia gan smarkiai firmware’ą laužyt. Tačiau kažkaip silpnai norisi tuo tikėt..

    Dar pradėjau svarstyt pastatyti papildomai „managed“ switch’ą po routeriu, bet nesu tinklistas, niekad nebandęs – tai nesu tikras ar suveiktų. Na, ir switch’ą tokį gauti nėra lengva („profesionalaus“ 24+ portų – tikrai nereikia). Mintis būtų, kad routeris (tikiuosi) galėtų siųst viską „as-is“ – ir toliau IPTV VLAN’ą būtų galima atfiltruoti switch’e, pastačius jį prieš pat Telia priedelį.

    Reply
    • Kol kas tokio varianto niekur negirdėjau dėl to pačio porto, nors dauguma rašo jog nori tai pasidaryti. Nemanau, kad ten baisiai jau firmware laužyti reikia, gal labiau su firewall sužaidžia.
      Del switch yra tų paprastų managed iš MikroTik berods. Bet pats neturiu tai patirtim nelabai pasidalinsiu.

    • Kas įdomiausia, tai kad skiriasi nustatymai, kuriuos IPTV priedelis gauna naudojant Telia routerį ir naudojant mano routerį su dedikuotu IPTV portu.

      Su Telia routeriu:
      – IP Address/Netmask: 192.168.0.65 / 255.255.255.0
      – IP Portal/DNS Server: 192.168.0.254 / 192.168.0.254

      Su mano routeriu + dedikuotas IPTV portas:
      – IP Address/Netmas: 10.197.127.192 / 255.255.0.0
      – IP Portal/DNS Server: 10.197.255.254 / 212.59.1.1, 212.56.2.2

      Taip išeina, kad su Telia routeriu viskas veikia tame pačiam tinkle..
      Kažkaip sugeba jis viduje sukombinuot VLAN’us ir gal paskui multicastin’a..

      Aš rašiau į Asus’o support’a, tai jų pirmas siūlymas buvo „enable multicast routing and IGMP snooping.“ Atrašiau jiems, kad to neužtenka ir pasakiau, kad per VLAN’ą sukonfiginta. Tai atrašė – „if the provider uses VLAN to transmit IPTV, it is possible to configure only through a dedicated port – IPTV STB port.“ Tai panašu, kad Telia routeris kažką tokio viduje ir padaro..

    • Seniau ir telia duodavo su 10. dabar tik ant naujesnių padarė 192.
      Tai gal telios inžinieriai žino, bet jie tikrai nesidalins tuo.

    • Aš panašioje situacijoje, tik jau turiu managed switch. Ar tau veikia IPTV su tavo routeriu ir dedikuotu IPTV portu kai pridėlio IP adresas 10.197***?

  • Čia gal ne visai į temą, bet ar galima xabar pasidaryti, kad telia IPTV matyti ant dviejų tv? Kokia nors telia priedelio kopiją pasidaryti ar ką nors panašaus. Kad vienu metu jie rodytų, tai to nereikia.

    Reply
    • Nebent ieškoti skelbimuose priedėlio jų, nes ribojimų ant ip adreso nėra.
      Arba mokėti nuomos mokestį ir dar vieną pasiimti.

  • Sveiki, truputi jau prarandu vilti, todel reikia pagalbos.
    Xiaomi R3P Pro routeris su openWRT.

    Su VLAN kaip ir atrodo viskas aisku, ekrano foto:
    ibb.co/Qk0xzZY

    bet visiskai neaisku su Interface:
    ibb.co/5kkyRJF

    kaip suprantu reikia sukurti nauja pvz IPTV interface:
    ibb.co/ChP5bJY
    bet jei sudedu bridge kaip foto, dingsta Internetas + neaisku su statiniais IP ar reikia deti kaip buvo parasyta :
    option ipaddr ‘10.10.99.99’
    option netmask ‘255.255.0.0’
    option gateway ‘10.218.255.254’

    ar isvis palikti su DHCP

    isbandziau viska, bet TV priedelis negauna IP ir viskas:
    ibb.co/6rW0QZ5

    su originaliu senu Zebra routeriu viskas veikia kaip laikrodis

    gal kazka ne taip darau ?

    Reply
  • Toks klausimas, gal kas susidures. Setupas yra sekantis: Telia technicolor routeris -> routeris1 -> routeris2. Pasijungus prie routerio1, internetas veikia, viskas ok. Pasijungus prie routerio2, interneto nebera. Panasu, kad tas ju technicoloras blokuoja reik per daug lygiu po juo pajungta.
    Bandziau roueryje1 nuresetint visu paketu TTL’a, tai internetas (antrajame) lyg ir atsirado, bet toks leisgyvis, panasu, kad arba nepkankamai gerai suconfiginau, arba pagal dar kazka blokuoja.
    Gal kas susidures ir turi kokiu patarimu? Routeris1 mikrotik, taigi galiu ten bet ka priconfiginti, tik reik zinoti ka 🙂

    Reply
    • Čia per visus nori TV pajungti ar kaip? Daugiau info reiktų, kas per schema ????

    • Ne, interneto noriu 🙂 Bet panasu kad blokuoja jei per daug „lygiu“ visko pasijungi. Nuo trecio routerio jai nebepraeina paketaiper teo routeri.

    • Kažkaip tikrai nemanau, kad kažką jau ten blokuotų, man rodos kažką per stipriai galvoji ir tikrai paprasčiau išsprendžiama.

  • Sveiki!
    Namie stovi „Technicolor TG389ac“, iš jo laidais pajungti 2 TV su išmaniąja Telia TV. Užsimaniau stipresnio WiFi ryšio prie antrojo TV (kuris yra 2-ame aukšte) – galvoju, pasistatysiu antrą router’į. Telioje davė „Technicolor TG789vacV2“. Jį pajungus prie ateinančio LAN kabelio antrame aukšte, nei internetas, nei TV neveikia. Kadangi abu, spėju, vienodai sukonfigūruoti (Local Device IP pas abu vienodi 192.168.1.254) – TG789vac routeryje pakeičiau į 192.168.2.254 (teko keisti ir DHCP Start ir End adress) – internetas atsirado. Deja, televizijos vistiek nerodo.
    Gal numanote ką dar reiktų pakeisti, kad pradėtų rodyti TV?

    Reply
    • O tiesiog tam antram DHCP išjungei? Arba mėginai sukeisti juos vietomis? Nepamenu ar abudu ar tik vienas sugeba paduoti TV, kad ir koks portas bus.

    • Pabandžiau kelis variantus:
      1-am nieko nekeičiau, 2-am DHCP įjungta – internetas 2-ame yra, TV neveikia;
      1-am nieko nekeičiau, 2-am DHCP atjungiau – internetas 2-ame yra, TV neveikia;
      2-ame įjungiau DHCP ir fiziškai sukeičiau vietomis su 1-mu:
      2-am nieko nekeičiau, 1-am DHCP įjungta – internetas 1-ame yra, TV neveikia;
      2-am nieko nekeičiau, 1-am DHCP atjungiau – internetas 1-ame yra, TV neveikia.

    • O veikia tas dalykas, kad nesvarbu koks portas vistiek eina TV? Čia kai su vienu būni.

    • Kai pajungi tik vieną router’į – ir 1-ame, ir 2-ame routeryje TV rodo nesvarbu į kurį LAN portą pajungsi: 1, 2, 3 ar 4.
      Beje, eksperimentuojant gavosi, kad TG789vacV2 paleidau su išjungtu DHCP – TV vistiek rodė per visus portus, tik internetas neveikė.

    • Dabar nepamenu, bet kažkas mėgino pasijungti su switchu tokį dalyką ir suveikė 🤔

Komentarai

El. pašto adresas nebus skelbiamas. Būtini laukeliai pažymėti *

Scroll to Top