Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 1

Skaitymo laikas: 4 minutės

Tekstas atnaujintas: 2020-08-14

Surašysiu Mikrotik nustatymus kuriuos pats naudoju. Kai kuriuos nustatymus galima ir kitaip susikonfigūruoti tvarkingiau, bet neturiu laiko nagrinėti. Svarbu viskas veikia ko man reikia.

Visus nustatymus patogu keisti naudojant WinBox.

Turima įranga: hAP ac²

Prenumeruok 🤟

Gauk į paštą žinutę apie naujus įrašus 👍

Cloud

Pirmas nustatymas būtų IP>Cloud įjungimas. Pagrinde tai suteikia tavo IP adresui nemokamą subdomain. Nereikės vesti namų IP adreso norint pasiekti. Taip pat padeda jeigu WAN adresas keičiasi.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 2
/ip cloud
set ddns-enabled=yes

MikroTik Telia konfigūracija

Internete klaidžioja pamoka, kaip pasijungti:

Mikrotik + TEO GALA TV

Maniau jog bus viskas paprasta, pagal pamoką, bet…

Pasirodo MikroTik atnaujino savo nustatymus ir panaikino master-port funkciją. Tad pagal pamoką, pusę komandų veikia, o toliau routeris mėto klaidas.

Master-port funkcijos tiesiog nėra.

Pradėjus Googlint kodėl neveikia master-port funkcija, pasirodo ties kažkuria RouterOS versija tai panaikino.

Dabar MikroTik siūlo tiesiog viską dėti į bridge. Panašiai, kaip naudojant TP-Link routerius kurie neturi atskiro eth, tarp switch nustatymų.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 3

Atsidarius interface, reikia sukurti vlan6 priskiriant interface wan.

Tada einam į bridge skiltį ir sukuriam naują bridge kuris bus skirtas IPTV.

Užtenka tik persivadinti, kaip norit, daugiau nieko keisti nereikia.

Tada einam į ports dalį, priskiriam tuos LAN portus katruos jungiam STB į sukurtą bridge.

Nepamirštam paspausti + ir pridėti vlan6 į tą bridge, mano atveju iptv-vlan6.

Realiai teorija tokia jog sujungiam viską, tiek portus, tiek tą sukurtą vlan6 į vieną bridge ir turim vaizdą per STB.

Taip pat reiktų įrašyti multicast paketą iš MikroTik puslapio.

Prie routerio modelio yra extra packages, kuriame yra įvairių paketų, kurių nėra pagal nutilėjimą.

Mums reiks multicast paketo, tada per WinBox atsidarom files ir nutempiam iš desktop tą failą, pekraunam routerį ir tada tarp packages galima įjungti.

Telia išmaniosios tv pajungimas naudojant switch nustatymus

Viename bloge radau komandas, kaip pasileisti panaudojus tik switch nustatymus ir nekuriant jokių bridge, tai atrodoo taip:

switch dalis, turint telia iptv mikrotik

Pagal pavadinimus galima suprasti jog ether4-STB ir ether5-STB turi nustatymus reikalingus priedėliams, nustatom lygiai taip pat, kaip pavaizduota.

WAN nustatymus taip pat svarbu taip nustatyti. Toliau kitką paliekam kaip buvo.

switch dalis, turint telia iptv mikrotikm antra dalis

Šitoje vietoje svarbu parašyti jog vlan id 6 ir sudėti portus, pirmas būtinai WAN, toliau eina priedėlio portai.

Beje, naudojant tokį būdą nesugalvojau, kaip pasileisti LRT kanalą per VLC.

LRT kanalas naudojant bridge

Kaip žinia Telia naudoja DRM apsaugas (kaip apeiti apsaugas, nežinau). Bet kažkodėl leidžia žiūrėti per VLC: LRT 1080p ir LRT 720p. Keista jog SD versijos neduoda.

Aišku jau reikia būti susitvarkius jog rodytų ir patys priedėliai.

IP>DHCP Client

Ties interface nurodyti bridge interface kuriame veikia IPTV. Nurodžius turi priskirti IP adresą kuris prasideda 10.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 4
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=wan
add add-default-route=no disabled=no interface=bridge-iptv use-peer-dns=no

Routing>Igmpproxy

Priskiriam tą patį bridge interface kuriame veikia IPTV ir bridge-lan kuriame veikia kiti įrenginiai.

Taip pat suvesti skaičius kurie suvesti pas mane ties alternative subnets.

/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add interface=bridge-lan
add alternative-subnets=10.0.0.0/7,224.0.0.0/4 interface=bridge-iptv upstream=yes
Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 5

Nuo dabar turėtų leisti pasiekti udp://@ adresus per VLC.

Tam reikalui naudoju astra-relay kuri įrašyta į NUC.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 6

Prievadų (portų) atidarymas

Savo įrangą visada noriu pasiektu iš išorės, tad reikia atidaryti kelis portus.

Jeigu noriu pasiekti routerį:

IP>Firewall>Filter Rules

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 7

Dažniausia naudojamas 80 portas routerio pasiekimui. Kadangi užimtas šis portas kitiems reikalams, tai teko MikroTik WEB portą  pakeisti į 81.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 8

Jeigu norim pasiekti su Winbox per išorę tada vietoje mano naudojamo porto 81 pakeisti į 8291.

/ip firewall filter add action=accept chain=input comment=winbox dst-port=8291 protocol=tcp

Jeigu norim pasiekti įrenginį kuris yra vietiniam tikle, reikės naudoti kitą komandą.

IP>Firewall>NAT

Reiktų sukurti WAN-IP adress list, kad leistų, būnant vidiniam tinkle, pasiekti vidinį tinklą su išoriniu adresu. Skamba gan kvailai, bet su tuo susidūriau naudojant tik Mikrotik.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 9
/ip firewall address-list add list=WAN-IP address=išorinis_adresas

Pradedam kurti taisyklę IP>Firewall>NAT

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 10

Dst. Port. tai portas kuris bus pasiekiamas iš išorės.

Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 11
Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 12

To Addresses tai adresas vietiniam tinkle. To Ports tai portas vietiniam tinkle į kurį bus nukreipta.

/ip firewall nat add action=dst-nat chain=dstnat dst-port=943 
 dst-address-list=WAN-IP protocol=tcp to-addresses=192.168.1.200 to-ports=943
Mikrotik Telia iptv konfigūravimas, bei kiti nustatymai 13

Extra skiltyje galima pridėti dar papildomų nustatymų prie atidaryto porto. Naudoju Time reikšmę kuri atidaro portą tik tam tikru laiku.


DNS nustatymų pakeitimas

Kaip žinia vis daugiau puslapių pradedama blokuoti (lažybų puslapiai, nelegalūs puslapiai). Pats blokavimas gan paprastas ir paremta tiesiog DNS adresais. Kreipiantis į domeno adresą o interneto tiekėjas tiesiog jus nukreipia kitur. 

Tad pasikeičiam DNS adresus ir pamirštam blokavimus.

Siūlau naudoti Cloudflare (1.1.1.1, 1.0.0.1) adresus, atsarginius Google (8.8.8.8, 8.4.4.8).

/ip dns
set allow-remote-requests=yes servers=1.1.1.1,1.0.0.1,8.8.8.8,8.4.4.8

Ar patiko įrašas?

Spausk jog įvertinti.

Vidutinis įvertinimas / 5. Įvertino:

Įvertinimų nėra, būk pirmas!

Jeigu įrašas patiko...

Pasidalink!

Jeigu įrašas nepatiko.

Padėk patobulinti įrašą!

Būtų malonu sužinoti kodėl?


Jeigu patiko įrašas, siūlau prenumeruoti, kaip tai padaryti aprašiau čia (el. paštu, telegram ir discord kanalai, facebook, twitter).

Gal patiks ir kiti įrašai